Bug 10389 - Very obscure screen+vim combo bug
Summary: Very obscure screen+vim combo bug
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-28 15:33 UTC by Steve Wills
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-30 14:46:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Wills 2000-03-28 15:33:21 UTC
As root on the console (not X), start screen, then run vim inside screen.
Enter some text, then press the backspace key. It displays a literal "^?"
instead of actually backspacing. Note this doesn't happen when doing this
from X or as any other user.

Comment 1 Luca Bonomi 2000-03-30 14:46:59 UTC
This happens to me when I "su" to another user and then run vi.
Note that it happens only for "konsole" and not for "kvt".
Maybe something wrong with the xterm terminfo.

Comment 2 Bernhard Rosenkraenzer 2000-10-17 09:44:59 UTC
Looks like the "screen" termcap and terminfo were out of sync; I can't reproduce
it w/ ncurses 5.1-5+termcap 11.0.1-3 anymore.


Note You need to log in before you can comment on or make changes to this bug.