Bug 103891 - Bad config syntax for /perl-status in default config
Summary: Bad config syntax for /perl-status in default config
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: mod_perl   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Gary Benson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-06 16:42 UTC by Ville Skyttä
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-09 09:24:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for /perl-status config (481 bytes, patch)
2003-09-06 16:43 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2003-09-06 16:42:13 UTC
The example configuration in /etc/httpd/conf.d/perl.conf for /perl-status in
1.99_09-8 doesn't work; Apache::Status seems to need Apache::compat and the
documentation at http://perl.apache.org/docs/2.0/api/Apache/Status.html uses the
modperl handler instead of perl-script.  Additionally, with the modperl handler,
"PerlOptions +GlobalRequest" seems to be needed.  Patch follows.

Comment 1 Ville Skyttä 2003-09-06 16:43:55 UTC
Created attachment 94279 [details]
Fix for /perl-status config

Comment 2 Gary Benson 2003-09-08 11:28:15 UTC
I've added the PerlModule Apache::compat line to perl.conf, but I left the other
two out.  The other example in the file uses the perl-script handler, so for
consistency I've left the status example using it too, and if you do change it
to modperl then it's pretty obvious that you need "PerlOptions +GlobalRequest".
 Does this seem reasonable?

Comment 3 Ville Skyttä 2003-09-08 15:12:37 UTC
Yes, I noticed that the perl-script / no PerlOptions +GlobalRequest combination
works too.  Sounds ok to me.  I'm not sure what to do with the status of this
bug so reassigning... :)

Comment 4 Gary Benson 2003-09-08 15:36:29 UTC
Reassigning is cool; I'll close it when I've built the new package...


Note You need to log in before you can comment on or make changes to this bug.