Bug 103899 - crontab -l keeps extraneous headers
Summary: crontab -l keeps extraneous headers
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vixie-cron (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 170805
TreeView+ depends on / blocked
 
Reported: 2003-09-06 20:33 UTC by Damian Menscher
Modified: 2007-04-18 16:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 22:49:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Damian Menscher 2003-09-06 20:33:28 UTC
Description of problem:
If you do a crontab -l it prefixes the user crontab with extra comments:

# DO NOT EDIT THIS FILE - edit the master and reinstall.
# (/tmp/crontab.20699 installed on Sat Sep  6 15:24:23 2003)
# (Cron version -- $Id: crontab.c,v 2.13 1994/01/17 03:20:37 vixie Exp $)

After several iterations of
 crontab -l > ctab
 vi ctab
 crontab ctab
you end up with a lot of extra headers.

That header is supposed to be in the cron file in /var/spool/cron, but NOT be
reported to the user.  Especially since there's no reason for them to not edit a
file they create via crontab -l.

Version-Release number of selected component (if applicable):
vixie-cron-3.0.1-74

How reproducible:
Always

Steps to Reproduce:
1. create user crontab
2. crontab -l

Actual Results:  Extra headers reported

Expected Results:  No headers... only user comments.

Comment 2 Jens Petersen 2004-06-30 17:58:16 UTC
Should be fixed in vixie-cron-3.0.1-94 in rawhide shortly.

Comment 3 Jason Vas Dias 2004-08-30 22:49:43 UTC
This has been fixed since vixie-cron-3.0.1-94 (current release
vixie-cron-4.1-10).


Note You need to log in before you can comment on or make changes to this bug.