Bug 1039016 - Kie-ci doesn't try to access additional remote repositories declared in settings.xml
Summary: Kie-ci doesn't try to access additional remote repositories declared in setti...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: BRE
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ER6
: 6.0.0
Assignee: Mario Fusco
QA Contact: Marek Winkler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-06 11:23 UTC by Mario Fusco
Modified: 2014-08-06 20:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 20:18:35 UTC
Type: Bug


Attachments (Terms of Use)
The KJAR built from KIE-WB (3.39 KB, application/x-java-archive)
2014-01-07 09:18 UTC, Marek Winkler
no flags Details
Maven project with reproducer and settings.xml (5.29 KB, application/zip)
2014-01-07 09:22 UTC, Marek Winkler
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1055022 0 medium CLOSED Kie-ci doesn't try to access additional remote plugin repositories declared in settings.xml 2021-02-22 00:41:40 UTC
Red Hat Issue Tracker DROOLS-367 0 Major Resolved Kie-ci doesn't try to access additional remote repositories declared in settings.xml 2015-05-21 01:52:38 UTC

Internal Links: 1055022

Description Mario Fusco 2013-12-06 11:23:34 UTC
In maven's settings.xml file it is possible to create additional profiles and declare additional remote repositories as in:

  <profiles>
    <profile>
      <id>guvnor-m2-profile</id>
      <activation>
        <activeByDefault>true</activeByDefault>
      </activation>
      <repositories>
        <repository>
          <id>guvnor-m2-repo</id>
          <name>Guvnor M2 Repo</name>
          <url>http://localhost:8080/m-kie-drools-wb-distribution-wars-6.0.0.Final-jboss-as7.0/maven2</url>
        </repository>
      </repositories>
    </profile>
  </profiles>

However kie-ci doesn't try to access this further repositories (as it should) when resolving a kjar.

Comment 1 Mario Fusco 2013-12-06 11:24:18 UTC
Fixed by https://github.com/droolsjbpm/drools/commit/74c702301

Comment 3 manstis 2013-12-06 19:41:23 UTC
Make Aether.getInstanc() public (required for Guvnor).

kie-ci
------
(master) http://github.com/droolsjbpm/drools/commit/9992dd41b

Fixes to dependent projects:

guvnor
------
(master) http://github.com/droolsjbpm/guvnor/commit/87f8fcb06

Comment 4 Lukáš Petrovický 2013-12-06 22:41:33 UTC
Much appreciated, guys!

Comment 5 Marek Winkler 2014-01-06 17:43:06 UTC
Verified on BRMS 6.0.0 ER7.

Comment 6 Marek Winkler 2014-01-07 09:16:29 UTC
Unfortunately, this problem is not completely solved:

I used the following method to test this issue:

1. I have created a simple java code which creates a new KieContainer with given ReleaseId (org.jboss.qa.brms:kie-ci-ext-artifact:1.0.0) - see attachments

2. in KIE-WB, I have created a new project with simple rule with corresponding GAV, and built it

3. I ran the test with custom settings.xml pointing to the KIE-WB repo (http://localhost:8080/business-central/maven2) and the test passed.

4. However, when I deleted the kjar created by KIE-WB from my ~/.m2/repository, KIE-CI failed to locate the kjar. KIE-CI probably should not to depend on the contents of ~/.m2/repository.

Please see the attachments for details.

Comment 7 Marek Winkler 2014-01-07 09:18:27 UTC
Created attachment 846522 [details]
The KJAR built from KIE-WB

Comment 8 Marek Winkler 2014-01-07 09:22:37 UTC
Created attachment 846523 [details]
Maven project with reproducer and settings.xml

Attached maven project with reproducer.

Please update settings.xml to point to your local KIE-WB and run  

mvn clean install -Dkie.maven.settings.custom=settings.xml

after you deploy the kjar in another attachemnt to KIE-WB.

Comment 9 Marek Winkler 2014-01-07 11:04:25 UTC
Sorry, my bad - I forgot to disable authentication for DownloadServlet serving the contents of business-central/maven2.

Verified with BRMS 6.0.0 ER7.


Note You need to log in before you can comment on or make changes to this bug.