Bug 1039023 - RFE: keep track of administratively stopped services and avoid autostarting them
RFE: keep track of administratively stopped services and avoid autostarting them
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: systemd-maint
qe-baseos-daemons
: FutureFeature
: 815243 (view as bug list)
Depends On:
Blocks: 909134
  Show dependency treegraph
 
Reported: 2013-12-06 06:56 EST by Karel Volný
Modified: 2013-12-06 07:46 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-06 07:46:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-12-06 06:56:33 EST
Description of problem:
I refer to bug 909134 - if the administrator stops a service, it may happen that it gets started via socket activation. This is undesired in many cases and breaks backwards compatibility of the service command. Manually stopped service should stay stopped until it gets manually started again (while "manually" means also as a dependency of another manually started service, or by explicit runlevel/target switch, which includes also reboot - masking the service instead of stopping it isn't an option here).
Comment 2 Karel Volný 2013-12-06 07:04:32 EST
*** Bug 815243 has been marked as a duplicate of this bug. ***
Comment 3 Lukáš Nykrýn 2013-12-06 07:39:05 EST
There are multiple reasons why I don't want to do this.
1) it would brake behavior of systemctl
2) service did not support socket activation in previous releases (xinetd), so current behavior is actually an improvement
3) service command never guaranteed that the service will be stopped forever, it could be started again by some other daemon even in the older releases
4) use mask --runtime which is specifically designed for this purpose
5) there is a warning that service could be started again
Comment 4 RHEL Product and Program Management 2013-12-06 07:46:38 EST
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.