Bug 10391 - Installer removes necessary LILO options
Summary: Installer removes necessary LILO options
Status: CLOSED DUPLICATE of bug 10390
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-28 15:46 UTC by Rob Russell
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-24 12:42:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rob Russell 2000-03-28 15:46:03 UTC
I did an upgrade from CD of a 6.1 installation to 6.2.  The video card was
an ATI XPert99 (Rage 128), so I was using XF86_FBDev and I had a VGA=791
line in lilo.conf.

The installer correctly upgraded XF86_FBDev, but reinstalled LILO without
the VGA=791 line.  The machine came up and kept tyring to start the X
Server unsucessfully.

The installer should pay very careful attention to /etc/lilo.conf for
things like this, as well as other things like boot passwords.

WORKAROUND:
At the LILO: prompt, type "linux 3" to bring the system up in text mode.
Log in as root, run "setup" and choose X Configuration.  It will then
detect the video card and install the correct XServer, and no longer need
the framebuffer.  Type "init 5" to bring the machine all of the way up.

Comment 1 Jay Turner 2000-04-24 12:42:59 UTC
The old lilo.conf is backed up to lilo.conf.rpmsave, so you can always flip over
at the end of the installation and make the appropriate changes.  We should have
this resolved in the next cut of the installer.

*** This bug has been marked as a duplicate of 10390 ***


Note You need to log in before you can comment on or make changes to this bug.