Bug 103916 - Evolution main window becomes non-responsive after clicking the close ("X") button
Evolution main window becomes non-responsive after clicking the close ("X") b...
Status: CLOSED DUPLICATE of bug 102554
Product: Red Hat Linux Beta
Classification: Retired
Component: evolution (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-07 10:21 EDT by Paul Morgan
Modified: 2007-04-18 12:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
shell script to kill evolution processes (165 bytes, text/plain)
2003-09-07 10:57 EDT, Tom "spot" Callaway
no flags Details

  None (edit)
Description Paul Morgan 2003-09-07 10:21:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Trying to close evolution causes it to become non-responsive. A pop-up prompts
user to force quit because the window is not responding. 

Client system is severn beta up2date against RHN. 
IMAP server is imap-2001a-18.

Version-Release number of selected component (if applicable):
evolution-1.4.4-5

How reproducible:
Always

Steps to Reproduce:
1. Open evolution against an imap server.
2. Click Send/Receive at least once.
2. Click the 'x' button at top-right of screen to close app.

    

Actual Results:  Pop-up that reports:
The window "INBOX (1) - Ximian Evolution" is not responding.

Forcing this application to quit will cause you to lose any unsaved changes.

Must click "force quit".

`ps -ef | grep evolution` then shows:
paul     32392     1  0 09:00 ?        00:00:00
/usr/libexec/evolution/1.4/evolution-wombat
--oaf-activate-iid=OAFIID:GNOME_Evolution_Wombat_InterfaceCheck --oaf-ior-fd=38
paul     32394     1  0 09:00 ?        00:00:00
/usr/libexec/evolution/1.4/evolution-alarm-notify
--oaf-activate-iid=OAFIID:GNOME_Evolution_Calendar_AlarmNotify_Factory
--oaf-ior-fd=40

These two procesesses must be killed before evolution will start again.


Expected Results:  App should close normally.

Additional info:

If I close out of evolution before clicking send/receive, then the app closes
normally.
Comment 1 Tom "spot" Callaway 2003-09-07 10:57:26 EDT
Created attachment 94285 [details]
shell script to kill evolution processes

Since I have this problem too (IMAP, evo won't shutdown properly), I revived an
old evolution favorite: killev. Its just a little shell script, and I'm sure it
could be done more eloquently, but it works for me (tm).
Comment 2 Jeremy Katz 2003-09-08 15:52:39 EDT
If you click cancel, does it eventually quit?  I think there's a timing issue
here where it gets carried away starting to clean up without pinging to say it's
still alive.
Comment 3 Paul Morgan 2003-09-09 10:39:37 EDT
Clicking cancel and leaving for as long as 8-9 minutes had no effect.
Comment 4 Jeremy Katz 2003-09-09 10:53:21 EDT
Can you attach to the process with gdb and see where it's spinning? 
evolution-debuginfo package is at
http://people.redhat.com/~katzj/evolution-debuginfo-1.4.4-5.i386.rpm
Comment 5 Paul Morgan 2003-09-12 07:36:05 EDT
Installed evolution-1.4.4-6 from RHN; bug still present. 
Comment 6 Nils Philippsen 2003-09-22 17:55:23 EDT
... still there with 1.4.4-7.
Comment 7 Nils Philippsen 2003-09-25 03:59:37 EDT

*** This bug has been marked as a duplicate of 102554 ***
Comment 8 Red Hat Bugzilla 2006-02-21 13:58:29 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.