Bug 103927 - /usr/bin/net-snmp-config should be in net-snmp-devel
/usr/bin/net-snmp-config should be in net-snmp-devel
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: net-snmp (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
David Lawrence
:
: 102040 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-07 16:22 EDT by Graham Leggett
Modified: 2015-03-04 20:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-08 06:02:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2003-09-07 16:22:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.4) Gecko/20030712

Description of problem:
While rebuilding the php RPM php-4.3.2-7.src.rpm from the current Rawhide, the
build bombs out like so:

/bin/sh /usr/src/redhat/BUILD/php-4.3.2/build-cgi/libtool --silent
--preserve-dup-deps --mode=compile gcc  -Iext/snmp/
-I/usr/src/redhat/BUILD/php-4.3.2/ext/snmp/ -DPHP_ATOM_INC
-I/usr/src/redhat/BUILD/php-4.3.2/build-cgi/include
-I/usr/src/redhat/BUILD/php-4.3.2/build-cgi/main
-I/usr/src/redhat/BUILD/php-4.3.2
-I/usr/src/redhat/BUILD/php-4.3.2/build-cgi/Zend -I/usr/include/libxml2
-I/usr/lib/include -I/usr/include/freetype2 -I/usr/include/imap
-I/usr/kerberos/include -I/usr/include/mysql -I/usr/include/pspell
-I/usr/include/ucd-snmp -I/usr/src/redhat/BUILD/php-4.3.2/main
-I/usr/src/redhat/BUILD/php-4.3.2/Zend -I/usr/src/redhat/BUILD/php-4.3.2/TSRM 
-I/usr/src/redhat/BUILD/php-4.3.2/build-cgi/TSRM  -O2 -g -march=i386 -mcpu=i686
-fPIC -I/usr/kerberos/include  -prefer-pic -c
/usr/src/redhat/BUILD/php-4.3.2/ext/snmp/snmp.c -o ext/snmp/snmp.lo 
In file included from /usr/src/redhat/BUILD/php-4.3.2/ext/snmp/snmp.c:84:
/usr/include/ucd-snmp/asn1.h:7:2: #error "Please update your headers or
configure using --enable-ucd-snmp-compatibility"
In file included from /usr/src/redhat/BUILD/php-4.3.2/ext/snmp/snmp.c:85:
/usr/include/ucd-snmp/snmp_api.h:7:2: #error "Please update your headers or
configure using --enable-ucd-snmp-compatibility"
In file included from /usr/src/redhat/BUILD/php-4.3.2/ext/snmp/snmp.c:86:
/usr/include/ucd-snmp/snmp_client.h:7:2: #error "Please update your headers or
configure using --enable-ucd-snmp-compatibility"

It is bombing out while trying to compile the SNMP section. The latest rawhide
version of net-snmp and net-snmp-devel are installed, and trying to add the
--enable-ucd-snmp-compatibility option makes no difference.

The underlying system is Redhat v9.

Version-Release number of selected component (if applicable):
php-4.3.2-7

How reproducible:
Always

Steps to Reproduce:
Build php.

Additional info:
Comment 1 Joe Orton 2003-09-07 16:36:01 EDT
What version of net-snmp and net-snmp-devel do you have?  Not seeing this here...

net-snmp-5.0.8-9.1
net-snmp-utils-5.0.8-9.1
net-snmp-devel-5.0.8-9.1
net-snmp-perl-5.0.8-9.1
Comment 2 Graham Leggett 2003-09-07 17:04:06 EDT
I tried the latest rawhide versions of net-snmp, and then downgraded to the
Redhat v9 version, same effect:

net-snmp-5.0.6-17
net-snmp-devel-5.0.6-17

It looks like php is including /usr/include/ucd-snmp instead of
/usr/include/net-snmp. Is this significant?

The error is only thrown if UCD_COMPATIBLE is set, and this is being added
somewhere despite this string not being found in the php source tree.
Comment 3 Graham Leggett 2003-09-07 17:12:00 EDT
More insight:

Turns out php is trying to find /usr/bin/net-snmp-config in order to work out if
net-snmp is installed. This file is part of net-snmp-utils, which was not
installed on my system. As a result, php tried to fall back to ucd-snmp, which
passes the configure test but breaks in the build.

So the problem is either a missing dependancy of php on net-snmp-utils, or
/usr/bin/net-snmp-config is in the wrong package.
Comment 4 Joe Orton 2003-09-07 17:23:13 EDT
Ah, thanks for tracking that down Graham - the latter is indeed correct.
Comment 5 Joe Orton 2003-09-07 18:16:02 EDT
*** Bug 102040 has been marked as a duplicate of this bug. ***
Comment 6 Phil Knirsch 2003-09-08 06:02:16 EDT
Moved net-snmp-config from net-snmp-utils to net-snmp-devel, will be in
net-snmp-5.0.8-10 and later.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.