Bug 1039359 - nkf`s manpage got garbled.
Summary: nkf`s manpage got garbled.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nkf
Version: 19
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-08 17:58 UTC by Masa Oshima
Modified: 2014-02-04 20:42 UTC (History)
5 users (show)

Fixed In Version: nkf-2.1.3-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-25 02:19:11 UTC


Attachments (Terms of Use)
bz#1039359 (nkf-bug#32546) patch (36.33 KB, patch)
2013-12-24 14:03 UTC, Masa Oshima
no flags Details | Diff

Description Masa Oshima 2013-12-08 17:58:29 UTC
Description of problem:
  nkf command`s manpage has got garbled in nkf-2.1.3 .

Version-Release number of selected component (if applicable):
  nkf-2.1.3-1.fc19.x86_64
  (At least, nkf version 2.1.2-7`s manpage works fine.)

How reproducible:
  Following command below.

Steps to Reproduce: 
  1. $ LC_MESSAGES=ja_JP.utf8 man nkf

Actual results:
nkf(1)                                                                                                            nkf(1)

NAME
       nkf - XXXXXXXXXXXXXXXXXX

(snip)

Expected results:
nkf(1)                                                                                                            nkf(1)

NAME
       nkf - ネットワーク用漢字コード変換フィルタ

(snip)


Additional info:
  I reported this problem to upstream team (http://sourceforge.jp/ticket/browse.php?group_id=248&tid=32546).

Comment 1 Masa Oshima 2013-12-24 13:33:37 UTC
Hi, Upstream team said 'It fixed.' on Dec 16 2013.

Comment 2 Masa Oshima 2013-12-24 14:03:55 UTC
Created attachment 841260 [details]
bz#1039359 (nkf-bug#32546) patch

I don`t have commit rights for Fedora-nkf-repository, So I can not -
execute 'git push' command.

Anybody else Developer? Could you please accept this pull-request ?


Create nkf.1j patch as nkf-2.1.3-nkf-bug-32546.patch:
$ cd my-upstream-clone-dir
$ git diff HEAD^..HEAD -- nkf.1j > ~/nkf-2.1.3-nkf-bug-32546.patch
$ 

Diff:
$ git format-patch origin/master
0001-Fix-nkf-s-manpage-got-garbled.-1039359.patch
$ 

Patch:
$ cd your-local-fedora-nkf-gitclone-dir
$ git am 0001-Fix-nkf-s-manpage-got-garbled.-1039359.patch
Applying: - Fix nkf`s manpage got garbled. (#1039359)
$ 


Note: I ignored 'man/make_doc.sh' file because it is NOT contains 'nkf-2.1.3.tar.gz' tar-ball.
upstream site: http://sourceforge.jp/ticket/browse.php?group_id=248&tid=32546
upstream site: http://git.sourceforge.jp/view?p=nkf/nkf.git;a=patch;h=c778b37ecf951d50195768deea665a3ebc9f9af6

Comment 3 Noriko Mizumoto 2014-01-03 00:47:34 UTC
Dear nfk package maintainer

Could you kindly have a look at this bug, and accept the patch to fix the issue for Japanese?

Comment 4 Fedora Update System 2014-01-15 11:38:41 UTC
nkf-2.1.3-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/nkf-2.1.3-2.fc20

Comment 5 Fedora Update System 2014-01-15 11:40:54 UTC
nkf-2.1.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/nkf-2.1.3-2.fc19

Comment 6 Fedora Update System 2014-01-16 07:00:36 UTC
Package nkf-2.1.3-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nkf-2.1.3-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0898/nkf-2.1.3-2.fc20
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-01-25 02:19:11 UTC
nkf-2.1.3-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-01-25 02:27:07 UTC
nkf-2.1.3-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Masa Oshima 2014-02-04 20:42:28 UTC
Now, ja-manpage works fine for me!
Thanks noriko-san and tagoh-san.


Note You need to log in before you can comment on or make changes to this bug.