Bug 103951 - /dev/ttyX hangs at random under moderate load
/dev/ttyX hangs at random under moderate load
Status: CLOSED DUPLICATE of bug 103950
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-08 07:23 EDT by Michael J. Cohen
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael J. Cohen 2003-09-08 07:23:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; .NET CLR 
1.1.4322)

Description of problem:
/dev/tty2 hangs when /dev/tty1 is producing a moderate CPU load and/or heavy IO.

killing the associated login process appears to reset the tty.

tested on two SMP machines ( dual 1GHz, ECC ) and a UP laptop.

Version-Release number of selected component (if applicable):
kernel-2.4.21-20.1.2024.2.1.nptl

How reproducible:
Always

Steps to Reproduce:
1. generate moderate to heavy CPU load and/or moderate to heavy CPU load
2. switch to tty2
3. generate moderate to heavy load, and press ctrl-c
    

Actual Results:  ctrl-c and every key pressed thereafter are ignored until 
affected /bin/login is killed.

Expected Results:  ctrl-c should have killed the process on tty2.

Additional info:

annoying :)
Comment 1 Bill Nottingham 2003-09-08 12:29:16 EDT

*** This bug has been marked as a duplicate of 103950 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:30 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.