Bug 1039577 - [RFE] Simplify repository dialog's Gpgcheck override mechanism
Summary: [RFE] Simplify repository dialog's Gpgcheck override mechanism
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 6.6
Assignee: Bryan Kearney
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2013-12-09 14:00 UTC by Michael Stead
Modified: 2014-10-14 07:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
no documentation required
Clone Of:
Environment:
Last Closed: 2014-10-14 07:46:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
create_override (430.62 KB, image/png)
2014-08-25 06:03 UTC, Rehana
no flags Details
remove_override (448.93 KB, image/png)
2014-08-25 06:04 UTC, Rehana
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description Michael Stead 2013-12-09 14:00:28 UTC
Description of problem:

Use a single checkbox to add/remove Gpgcheck override, and display an icon to the right of the checkbox to indicate that an override has been created.

With the current implementation, an override is created as soon as the edit button is clicked and the drop down is shown. This happens regardless of if the default value changes. We could automatically flip the default boolean value when the edit button is clicked, but this would be no different than using a checkbox as described above. The edit and remove buttons are not required since there are only 2 possible values for gpgcheck. One of which is the default value from the certificate.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Carter Kozak 2014-07-25 12:45:58 UTC
commit f7589252777f6028948233d02bddad2284d3e683
Author: ckozak <ckozak@redhat.com>
Date:   Wed Jul 9 15:14:00 2014 -0400

    1039577: simplify reposgui gpgcheck control

Comment 3 Bryan Kearney 2014-07-30 19:23:54 UTC
Acking 7.1

Comment 4 John Sefler 2014-08-20 12:26:58 UTC
This has been merged into subscription-manager-1.12.8-1 and will be delivered with RHEL6.6.

Moving back to RHEL6.6

Comment 5 Rehana 2014-08-25 06:01:11 UTC
Retested on,

# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.21-1
subscription management rules: 5.11
subscription-manager: 1.12.13-1.el6
python-rhsm: 1.12.5-1.el6


Observed that a single checkbox to add/remove Gpgcheck override has been implemented. as result of this now override is added only when there is change from the default repo value

PFA:create_override.png
PFA:remove_override.png

Marking Verified

Comment 6 Rehana 2014-08-25 06:03:21 UTC
Created attachment 930334 [details]
create_override

Comment 7 Rehana 2014-08-25 06:04:14 UTC
Created attachment 930335 [details]
remove_override

Comment 10 errata-xmlrpc 2014-10-14 07:46:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.