Bug 103962 - RFE: Needs Reboot status (for kernel updates)
RFE: Needs Reboot status (for kernel updates)
Status: CLOSED DUPLICATE of bug 783145
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
: FutureFeature
Depends On:
Blocks: 260381
  Show dependency treegraph
 
Reported: 2003-09-08 09:56 EDT by Josiah Royse
Modified: 2012-02-29 14:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 14:09:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josiah Royse 2003-09-08 09:56:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

Description of problem:

It would be great to see the web interface for RHN have some type of
notification when viewing the systems on which need a reboot for kernel updates.
 This feature would be very useful when combined with the "auto updates"
feature- if the machine has been updating itself, we don't want it to have to
reboot itself, but rather inform admins of that status - "Needs rebooted".  

Maybe the "kernel version" line in the system details could be high-lighted
__RED__ noting the kernel running is old, compared with the rpm version
installed.  I understand this might be annoying if customers were booting a
custom kernel- but perhaps the rhnsd would be able to determine this.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. load OS
2. update kernel/misc rpms via RHN
3. notice machine is up to date, running the old kernel version
    

Actual Results:  Sure, the machine is up to date, but only after a reboot.

Expected Results:  Perhaps a highlighted "kernel version" in system details, or
a highlighted notice under the general systems tab would be super.

Additional info:
Comment 3 Clifford Perry 2012-02-29 14:09:35 EST

*** This bug has been marked as a duplicate of bug 783145 ***

Note You need to log in before you can comment on or make changes to this bug.