Bug 103978 - autopartition generates bad partitions
autopartition generates bad partitions
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: parted (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-08 14:42 EDT by Pete Nishimoto
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-25 15:24:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
details on anaconda autoparotion failues (34.16 KB, text/plain)
2003-09-08 14:47 EDT, Pete Nishimoto
no flags Details

  None (edit)
Description Pete Nishimoto 2003-09-08 14:42:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79C-CCK-MCD  [en] (X11; U; SunOS 5.9 sun4u)

Description of problem:
When using autopartition, depending upon the geometry of the disk, 
partitions may be allocated which are not on sector boudnaries.
Thus, during installation, if the autopartitioned disk is to be
scanned prior to package installation, if the partition is
NOT on a sector boundary, badblocks will fail and the installation
process will stop

See attachment for more (lots more) details

Version-Release number of selected component (if applicable):
anaconda-9.0

How reproducible:
Always

Steps to Reproduce:
1.select autopartition and scan the partitions created		
2.select more packages than room on the partition
3.after the 1st badblocks scan, anaconda will notice that there isn't
  enough room.  Remove packages until they all fit on the partition
4.disk will be scanned a 2nd time.  If the partition is not on a 
  cylinder boundary, badblocks will fail and the installation will 
  stop
    

Actual Results:  badblocks fails and installation stops		

Expected Results:  badblocks success and installation continues

Additional info:
Comment 1 Pete Nishimoto 2003-09-08 14:47:37 EDT
Created attachment 94311 [details]
details on anaconda autoparotion failues

This attachment contins detailed debug analysis of the problem and
possible fixes
Comment 2 Michael Fulbright 2003-09-10 15:12:35 EDT
This looks like its related to how parted aligns partition requests. 

Note You need to log in before you can comment on or make changes to this bug.