Bug 1039841 - Copying multiple files freezes on second file on smb mount
Summary: Copying multiple files freezes on second file on smb mount
Alias: None
Product: Fedora
Classification: Fedora
Component: gvfs
Version: 19
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Ondrej Holy
QA Contact: Fedora Extras Quality Assurance
Depends On: 698633
TreeView+ depends on / blocked
Reported: 2013-12-10 07:03 UTC by Martin Sourada
Modified: 2015-02-17 19:35 UTC (History)
5 users (show)

Clone Of: 698633
Last Closed: 2015-02-17 19:35:53 UTC

Attachments (Terms of Use)

Description Martin Sourada 2013-12-10 07:03:28 UTC
+++ This bug was initially created as a clone of Bug #698633 +++

Description of problem:
When I try to copy multiple files (e.g. a folder with files) from samba share (windows active directory), main process freezes on second file and never (I tried waiting for 2 hours) recovers. I tried it in Thunar and mc in the first one just the copying process freezes and cannot be canceled, in mc it freezes whole terminal. Using Dolphin (which seems to not use gvfs for mounting samba shares) works fine. Copying single file works. The remote location also becomes "ununmountable" (cannot be unmounted).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Mount remote AD folder via gvfs
2. Try to copy several files from it.

Actual results:

Expected results:
Files copy without issues.

Additional info:

Comment 1 Julio Sanchez Fernandez 2014-01-02 08:07:31 UTC
I am experiencing something very similar. I cannot promise it happens on the second file everytime, though. Accessing files through gvfs-smb are unreliable. Operations do not complete and are unkillable. For instance, nautilus transfers endup as pending and cannot be stopped. Firefox and gthumb. Killing them makes them zombies, parented by process 1 but never reaped. Restarting the user session has worked in some cases to recover from this situation, I am not sure if it is always effective. Killing gvfs-smb instances has worked for me once, but I think I have seen one hang where no gvfs-smb process seemed a good candidate for killing.

I am also experimenting similar problems with gvfs-gphoto2, but this might be a different problem.

The smb bug, at least, seems related to upstream:


Comment 2 Fedora End Of Life 2015-01-09 20:49:35 UTC
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 3 Fedora End Of Life 2015-02-17 19:35:53 UTC
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.