Bug 104 - Kernel 2.0.36 / pcmcia-cs-3.0.5 incompatibility
Kernel 2.0.36 / pcmcia-cs-3.0.5 incompatibility
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
5.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-17 10:01 EST by roberts
Modified: 2014-03-19 07:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-11-23 11:21:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description roberts 1998-11-17 10:01:24 EST
If you build a custom kernal w/RH 5.2 using the supplied
2.0.36 kernel source and the distributed pcmcia-cs-3.0.5
source, pcmcia/card_services will not work.

Platform: Gateway 2000 9100XL laptop, 266 P-II, 192 MB ram.
Comment 1 dattaway 1998-11-18 11:09:59 EST
Would the following be helpful?

With my Gateway Solo 2200, I have built the supplied kernel with the
pcmcia-cs-3.0.5 and it works, except for the pcmcia automatic
suspend/resume, and just one of my cards, a NE2000 compatible network
card does not load:

 Nov 18 13:08:17 localhost cardmgr[205]: initializing socket 0
Nov 18 13:08:17 localhost cardmgr[205]: socket 0: EZLink 4109 Ethernet
Nov 18 13:08:17 localhost cardmgr[205]: executing: 'insmod
/lib/modules/2.0.36/net/8390.o'
Nov 18 13:08:17 localhost cardmgr[205]: executing: 'insmod
/lib/modules/2.0.36/pcmcia/pcnet_cs.o'
Nov 18 13:08:17 localhost cardmgr[205]: +
/lib/modules/2.0.36/pcmcia/pcnet_cs.o: unresolved symbol
unregister_netdev_R83363374
Nov 18 13:08:17 localhost cardmgr[205]: +
/lib/modules/2.0.36/pcmcia/pcnet_cs.o: unresolved symbol
register_netdev_Re4ba25d3
Nov 18 13:08:17 localhost cardmgr[205]: insmod exited with status 1
Nov 18 13:08:17 localhost cardmgr[205]: executing: 'modprobe pcnet_cs'
Nov 18 13:08:18 localhost cardmgr[205]: + can't locate module pcnet_cs
Nov 18 13:08:18 localhost cardmgr[205]: modprobe exited with status 1
Nov 18 13:08:19 localhost cardmgr[205]: get dev info on socket 0
failed: Resource temporarily unavailable
Comment 2 Cristian Gafton 1998-11-18 21:10:59 EST
We need a much more explicit explanation of the "will not work" part.
Comment 3 Preston Brown 1998-11-23 11:21:59 EST
This is understood to be the case, because the symbols from the pcmcia
package don't match the symbols in the new kernel.  You will need to
rebuild the pcmcia package against the new kernel from the source RPM,
or get the updated kernel RPMs from updates.redhat.com.

Note You need to log in before you can comment on or make changes to this bug.