Bug 104021 - CS4236B not working with 2.6.0-0.test4.1.33
Summary: CS4236B not working with 2.6.0-0.test4.1.33
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-09 01:46 UTC by Eric Bursley
Modified: 2007-04-18 16:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 15:41:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Bursley 2003-09-09 01:46:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
Unable to load CS4236B sound module.  modprobe reports no device.  However on
boot it is detected.
isapnp: Scanning for PnP cards...
PM: Adding info for No Bus:00:01
PM: Adding info for pnp:00:01.00
PM: Adding info for pnp:00:01.01
PM: Adding info for pnp:00:01.02
PM: Adding info for pnp:00:01.03
PM: Adding info for No Bus:00:02
PM: Adding info for pnp:00:02.00
isapnp: Card 'CS4236B'
isapnp: Card 'U.S. Robotics 56K FAX INT'
isapnp: 2 Plug & Play cards detected total


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install 2.6.0 test kernels on CS4236B such as Dell Optiplex GX1
2. run modprobe cs4236
3.
    

Actual Results:  No sound since 2.4.x kernels

Expected Results:  module CS4236B will load and system will have sound capabilities.

Additional info:

I have tried configuring alsa, but I'm lost in the configuration.  I've read
where Alan Cox has stated that the PnP layer has changed somewhat in the 2.5
series, and that the author will need to provide examples on how to update all
PnP drivers.

Comment 1 Thomas Gordon 2003-11-13 23:52:30 UTC
I too get no sound on GX1.  Modules load fine.  Tried reloading all
modules.  Not a peep.  Device shows in /proc/isapnp fine.

Comment 2 Bugzilla owner 2004-09-30 15:41:31 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/



Note You need to log in before you can comment on or make changes to this bug.