This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 104022 - Undefined subroutine &DBD::Pg::db::pg_server_version
Undefined subroutine &DBD::Pg::db::pg_server_version
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: perl-DBD-Pg (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-08 22:16 EDT by Ted Kaczmarek
Modified: 2007-04-18 12:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-21 13:51:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ted Kaczmarek 2003-09-08 22:16:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Epiphany/0.9.3

Description of problem:
When istalling latest version of Opennms on severn I was geting
"Undefined subroutine &DBD::Pg::db::pg_server_version called at
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/DBD/Pg.pm line 911."

I downgraded it to  perl-DBD-Pg-1.21-2.i386.rpm and the install completed.

Version-Release number of selected component (if applicable):
perl-DBD-Pg-1.22-1

How reproducible:
Always

Steps to Reproduce:
1.Download opennms-1.1.2-1
2.Try installing
3.
    

Actual Results:  Error during install, Undefined subroutine
&DBD::Pg::db::pg_server_version called at
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/DBD/Pg.pm line 911.
.

Expected Results:  Install completes.

Additional info:

This is severn with the 2.4.22-20.1.2024.2.36.nptl kernel.
Comment 1 Max Kanat-Alexander 2003-11-13 16:26:29 EST
I can confirm this bug on Fedora Core 1 -- it prevents me from
installing Red Hat's bugzilla for use at our organization.

-M
Comment 2 Maxwell Kanat-Alexander 2003-12-31 17:08:51 EST
Can we get the latest DBD::Pg thrown in to Fedora? It looks like 1.31
has been released, now. It would probably resolve this issue.

-M
Comment 3 Maxwell Kanat-Alexander 2003-12-31 17:19:31 EST
*Ping* (I think that the previous comment didn't send an email because
of a software error in BZ.)
Comment 4 Maxwell Kanat-Alexander 2004-02-13 14:53:42 EST
I can confirm that perl-DBD-Pg 1.31 resolves this issue. So I assume
that it will be resolved in FC2.

-M

Note You need to log in before you can comment on or make changes to this bug.