Bug 1040260 - Non-functioning webcam ID 04f2:b302
Summary: Non-functioning webcam ID 04f2:b302
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-11 03:40 UTC by Daniel Wang
Modified: 2013-12-12 23:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-12 23:19:41 UTC


Attachments (Terms of Use)
dmesg log (251.27 KB, text/plain)
2013-12-11 03:40 UTC, Daniel Wang
no flags Details
output of lsusb -d 04f2:b302 -v (25.13 KB, text/x-log)
2013-12-11 03:41 UTC, Daniel Wang
no flags Details

Description Daniel Wang 2013-12-11 03:40:22 UTC
Created attachment 835095 [details]
dmesg log

Description of problem:
I can't get the built-in webcam working on my Fujitsu Lifebook AH532.

Version-Release number of selected component (if applicable):
Fedora 19 
kernel-3.11.10-200.fc19.x86_64 
kernel-3.11.9-200.fc19.x86_64

How reproducible: Always


Steps to Reproduce:
1. Try any webcam/video app (e.g. Cheese, guvcview, ffmeg, etc.)

Actual results:
dmesg: 
[ 1089.114259] usb 1-1.4: new high-speed USB device number 10 using ehci-pci
[ 1089.297819] usb 1-1.4: New USB device found, idVendor=04f2, idProduct=b302
[ 1089.297828] usb 1-1.4: New USB device strings: Mfr=2, Product=1, SerialNumber=0
[ 1089.297833] usb 1-1.4: Product: FJ Camera
[ 1089.297878] usb 1-1.4: Manufacturer: Chicony Electronics Co., Ltd.
[ 1089.302355] uvcvideo: Found UVC 1.00 device FJ Camera (04f2:b302)
[ 1089.328153] input: FJ Camera as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.0/input/input141
[ 1091.223734] usb 1-1.4: USB disconnect, device number 10
[ 1091.225219] uvcvideo: Failed to resubmit video URB (-19).


Expected results:
App captures images from webcam.


Additional info:
dmesg and lsusb logs attached, with uvcvideo module tracing on (suggested by www.ideasonboard.org/uvc/faq )

Comment 1 Daniel Wang 2013-12-11 03:41:58 UTC
Created attachment 835096 [details]
output of  lsusb -d 04f2:b302 -v

Comment 2 Daniel Wang 2013-12-12 23:19:41 UTC
Playing around with the system a bit more, I was able to make it work sporadically by re-connecting the motherboard connector. I don't think this is a kernel or Fedora problem any more. Closing as not a bug.


Note You need to log in before you can comment on or make changes to this bug.