Bug 104030 - End of internet config when apply button is clicked get a Exception Occurred
Summary: End of internet config when apply button is clicked get a Exception Occurred
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: internet-config (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-09 06:29 UTC by Bill Burkhardt
Modified: 2007-04-18 16:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-10 16:14:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Burkhardt 2003-09-09 06:29:34 UTC
Description of problem:At the end of setting up internet connection wizzard to
apply settings, receive error message Unhandeled Exceptin Occurred, "NameError:
global name 'timeout_add' is not defined" 


Version-Release number of selected component (if applicable):


How reproducible:Every time I try to setup internet connection through wizzard.


Steps to Reproduce:
1.Follow steps in the wizzard for modem setup
2.fill in required info
3.click on Apply button
    
Actual results:error message 


Expected results:Save and finish?


Additional info:have an existing connection through LAN

Comment 1 Bill Burkhardt 2003-09-09 06:33:20 UTC
Cut---->below from error message:

Component: redhat-config-network
Version: 1.2.0
Summary: TB4a5c5e6f maindialog.py:198:__init__:NameError: global name
'timeout_add' is not defined
Traceback (most recent call last):
  File "/usr/sbin/internet-druid", line 154, in ?
    window = mainDialog()
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 198, in __init__
NameError: global name 'timeout_add' is not defined

Local variables in innermost frame:
widget: <gtk.VBox object (GtkVBox) at 0x86796d4>
notebook: <gtk.Notebook object (GtkNotebook) at 0x8788f44>
page: 0
glade_file: /usr/share/redhat-config-network/netconfpkg/gui/maindialog.glade
self: <netconfpkg.gui.maindialog.mainDialog instance at 0x866ee04>


Comment 2 Bill Burkhardt 2003-09-09 07:22:37 UTC
Also Get the same error just by trying to run Network config..."neat". Never get
to the config of the network

Comment 3 Ngo Than 2003-09-10 09:24:20 UTC
it should be fixed in redhat-config-network-1.2.15, which was released as errata
in august. You should upgrade to this version.

Comment 4 Bill Burkhardt 2003-09-10 13:03:25 UTC
You'll have to please excuse me because I'm new at this and I don't know all 
the correct wording, but I guess I should have mentioned that this happened 
after I ran the upgrade for the "errata"'s. So I'm thinking that maybe I got a 
courrupt file in some way, but I thought the file checking would have found 
this out when it was applied or transfered. So I should try again 
run "up2grade" and force the overwright since I applied the "fix" that supposed 
to fix this?  

Comment 5 Bill Burkhardt 2003-09-10 13:19:36 UTC
Also, maybe this should be closed? 

I had to take this machine out of the network and will not be able to run the 
upgrade - errata for a few days. But first would you let me know or post the 
name of the errata file that I need that corrects this problem to replace. 
TIA

Comment 6 Ngo Than 2003-09-10 16:14:55 UTC
it's redhat-config-network-1.2.15


Note You need to log in before you can comment on or make changes to this bug.