Bug 104036 - stty incorrectly changes terminal settings
Summary: stty incorrectly changes terminal settings
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sh-utils (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-09 11:21 UTC by Norman Stevens
Modified: 2007-04-18 16:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 16:40:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from script showing terminal settings (3.66 KB, text/plain)
2003-09-09 11:22 UTC, Norman Stevens
no flags Details

Description Norman Stevens 2003-09-09 11:21:04 UTC
Description of problem:
su incorrectly changes the stty settings

Version-Release number of selected component (if applicable):
sh-utils 2.0.11

How reproducible:
Log in to RedHat linux machine with ssh/telnet/whatever then
su to root.

Steps to Reproduce:
1. use telnet/ssh/whatever to log in to linux machine.
2. su to root or other user.

    
Actual results:
When initially logged in the terminal settings are correct.
After su the terminal settings are incorrect. Specifically
erase has been set to ^?.

Expected results:
Terminal settings should be unchanged. stty -a should report
the settings as set on remote machine prior to logging in.

Additional info:

Comment 1 Norman Stevens 2003-09-09 11:22:53 UTC
Created attachment 94318 [details]
output from script showing terminal settings

Comment 2 Tim Waugh 2003-09-09 15:59:48 UTC
This seems to be casued by the /etc/bashrc invocation of stty.

lhh: Was that causing problems with screen(1) as well did you say?

Comment 3 Lon Hohberger 2003-09-09 16:26:51 UTC
Sort of.  Screen only works properly with "stty `tput kbs`".

This is reminiscent of:

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=91357

Comment 4 Tim Waugh 2004-12-07 11:43:33 UTC
Is this all fixed now?  I remember there were some changes in screen.


Note You need to log in before you can comment on or make changes to this bug.