Bug 104047 - Support for Dell Inspiron 8500 including ACPI, Speedstep, Multimedia Keys, Hotswapping, Screen Resolution
Support for Dell Inspiron 8500 including ACPI, Speedstep, Multimedia Keys, Ho...
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-09-09 09:33 EDT by Robert Brimhall
Modified: 2015-01-04 17:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-10-27 09:55:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Robert Brimhall 2003-09-09 09:33:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
This is a popular model laptop and as such should be targeted for full support
asap. Of course this is not including the winmodem. But having to patch my dsdt
to get acpi working is a bummer.

See this link for an example of the trials necessary to get Linux running...
although once it's running it runs great!


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install Red Hat Linux (any)
2.Work on your Laptop after strugging to configure X due to the uncommon screen
3.Watch your laptop overheat and battery power not hold up due to improper power

Additional info:
Comment 1 Dave Jones 2003-09-09 10:03:44 EDT
Have you tried the latest kernel from rawhide ?
It has updated ACPI, and the Speedstep-ich cpufreq module.

Comment 2 Robert Brimhall 2003-09-09 11:38:31 EDT
Yes, I think it is due to Dell's BIOS being Blacklisted... the DSDT needs to be
patched in order to get ACPI support that works... I'm just suggesting this be
included in any upcoming releases.
Comment 3 Dave Jones 2003-09-09 12:14:51 EDT
why is it being blacklisted ? If its because its pre-2000, you can override with
Comment 4 Robert Brimhall 2003-09-09 12:46:40 EDT
Dell Inspiron 8500
Last Modified 	2003-07-09 14:46 by Adrian Dewhurst 	S4 Bios 	no
Original 	no 	SMP 	no
Bios Revision 	A03 	APIC Table 	no
Board Revision 		Boot Table 	no
DSDT Vendor 		S2 Latency 	0
DSDT Product 		S3 Latency 	0
DSDT Revision 	0 	Dutywidth 	0
Interpreter Fix 	Dell's code incorrectly assumes that all arguments are passed
by reference, when they are actually passed by value. There are two methods
affected by this, so they have been modified to explicitly pass references.

It has been removed from the blacklist apparently but the bios is buggy... a
patch is still needed to get it to work correctly...
Comment 5 Robert Brimhall 2003-09-09 19:04:22 EDT

see this site
Comment 6 Dave Jones 2003-10-03 14:42:35 EDT
No updated BIOS available ?
Comment 7 Robert Brimhall 2003-10-08 22:19:28 EDT
Yeah, Kernel 2.4.22 seems to be running smoothly with default acpi and patched
cpufreq with an updated bios. Still no support for volume keys other than acme
(a good userland solution but only with GNOME and XFce4 with work)... also,
i8kutils required for fan control...
Comment 8 Robert Brimhall 2003-10-08 22:20:37 EDT
Kernel 2.4.22 vanilla sources... not red hat version but they should be the same
minus red hat's tweaks.

Note You need to log in before you can comment on or make changes to this bug.