Bug 104050 - rpm -q segfault
rpm -q segfault
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-09 10:09 EDT by Michael Redinger
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-11 05:53:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
rpm -q gawk-3.1.1-9 strace output (34.81 KB, text/plain)
2003-09-09 10:11 EDT, Michael Redinger
no flags Details
rpm -q grub-0.93-4 strace output (36.37 KB, text/plain)
2003-09-09 10:12 EDT, Michael Redinger
no flags Details
rpm -q gzip-1.3.3-9 strace output (36.37 KB, text/plain)
2003-09-09 10:13 EDT, Michael Redinger
no flags Details

  None (edit)
Description Michael Redinger 2003-09-09 10:09:26 EDT
For some packages, rpm seg faults if the package specified is
name-version-release. If I only query name-version, it works fine.

Example (run as root):

# rpm -q gawk-3.1.1-9
Segmentation fault
# rpm -q gawk-3.1.1
gawk-3.1.1-9


This worked fine for all other packages in beta2 for me when run as root.
But when I run this as non-root, there are two more packages that cannot be
queried this way:

$ rpm -q grub-0.93-4
Segmentation fault
$ rpm -q gzip-1.3.3-9
Segmentation fault

I am attaching the strace output of the three failed queries.
Comment 1 Michael Redinger 2003-09-09 10:11:12 EDT
Created attachment 94327 [details]
rpm -q gawk-3.1.1-9 strace output
Comment 2 Michael Redinger 2003-09-09 10:12:02 EDT
Created attachment 94328 [details]
rpm -q grub-0.93-4 strace output
Comment 3 Michael Redinger 2003-09-09 10:13:26 EDT
Created attachment 94329 [details]
rpm -q gzip-1.3.3-9 strace output
Comment 4 Matt Wilson 2003-09-09 11:47:48 EDT
works for me:

[msw@sid lib]$ rpm -q gawk-3.1.1-9
gawk-3.1.1-9
[msw@sid lib]$ rpm -q grub-0.93-4
grub-0.93-4
[msw@sid lib]$ rpm -q gzip-1.3.3-9
gzip-1.3.3-9
[msw@sid lib]$ rpm -q rpm
rpm-4.2.1-0.31

Can you use gdb, that is more useful than strace in getting a diagnosis.
Comment 5 Michael Redinger 2003-09-09 12:53:27 EDT
I am trying to do so (rebuilt rpm and installed debuginfo), but ddd/gdb keep
telling me 
"[New Thread -1218546256 (LWP 12320)]
Cannot find user-level thread for LWP 12320: generic error"

However, I found out more:

# LANG=en_US.UTF-8 rpm -q gawk-3.1.1-9
Segmentation fault
# LANG=en_GB.UTF-8 rpm -q gawk-3.1.1-9
Segmentation fault
# LANG=C rpm -q gawk-3.1.1-9
gawk-3.1.1-9
# LANG=de_AT rpm -q gawk-3.1.1-9
gawk-3.1.1-9
# LANG=de_AT.UTF-8 rpm -q gawk-3.1.1-9
gawk-3.1.1-9
# LANG=de_DE.UTF-8 rpm -q gawk-3.1.1-9
gawk-3.1.1-9

(Same for the other packages, when run as normal user)

Can you reproduce it now?
Comment 6 Michael Redinger 2003-09-09 12:57:07 EDT
I forgot this one:

# LANG=en_US.UTF-8 LC_MESSAGES=C rpm -q gawk-3.1.1-9
gawk-3.1.1-9
Comment 7 Matt Wilson 2003-09-09 12:58:55 EDT
still can't reproduce
Comment 8 Matt Wilson 2003-09-10 16:31:26 EDT
try rpm --rebuilddb?
Comment 9 Michael Redinger 2003-09-11 05:53:10 EDT
Forgot that one.
It actually helps - I do not know why ... closing.


Note You need to log in before you can comment on or make changes to this bug.