Bug 104053 - httpd failes to bind when restarting
Summary: httpd failes to bind when restarting
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-09 14:30 UTC by Fredrik Rambris
Modified: 2015-01-08 00:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-17 09:44:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fredrik Rambris 2003-09-09 14:30:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
At system boot up httpd starts just fine but when I want to restart it i get:
Starting httpd: (98)Address already in use: make_sock: could not bind to address
0.0.0.0:80
no listening sockets available, shutting down


Version-Release number of selected component (if applicable):
httpd-2.0.40-20

How reproducible:
Always

Steps to Reproduce:
1. Start the machine with apache
2. Run service httpd restart
3.
    

Actual Results:  Starting httpd: (98)Address already in use: make_sock: could
not bind to address 0.0.0.0:80
no listening sockets available, shutting down

Expected Results:  It should have restarted as usual.

Additional info:

Comment 1 Joe Orton 2003-09-09 14:45:11 UTC
After a failed restart, what is the output of:

# tail /var/log/httpd/error_log
# netstat -pant | grep :80


Comment 2 Fredrik Rambris 2003-09-10 20:05:12 UTC
[root@wonka root]# netstat -pant | grep :80
tcp    0    0.0.0.0:80      0.0.0.0:*         LISTEN   1180/ppp-watch


This is the only line that's added to error_log
[Wed Sep 10 21:57:21 2003] [notice] caught SIGTERM, shutting down

When killing pppd and ppp-watch httpd starts normaly.

Why would ppp-watch bind to port 80?

I have initscripts-6.95-1 installed.

Comment 3 Joe Orton 2003-09-10 20:13:55 UTC
I'm not familiar with ppp-watch, is it acting as configured? 

Comment 4 Fredrik Rambris 2003-09-10 20:45:44 UTC
I have not touched it. I don't really know what it is more than what the man
page sais. All configuration of ppp is done via redhat-config-network. I guess
it's started from ifup scripts.

Comment 5 Thomas Woerner 2004-08-17 09:44:47 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.


Note You need to log in before you can comment on or make changes to this bug.