Bug 10406 - default pine.conf silliness
Summary: default pine.conf silliness
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pine   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-29 03:55 UTC by Jeremy Katz
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-17 17:16:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
get rid of nasty colors (1.74 KB, patch)
2000-03-29 03:55 UTC, Jeremy Katz
no flags Details | Diff

Description Jeremy Katz 2000-03-29 03:55:27 UTC
the default /etc/pine.conf as of 6.2 is... silly for lack of a  better
word.  By setting default colors, you override a person's preference to
what colors their terminals are, which is not expected behavior at all.
Having pine pop up with a black background in a transparent terminal is...
different.

The removal of the lower color sections makes it play nicer; not removing
the color-style causes a nice cyan background.

Attaching a patch for the pine.conf to make it play nicer

Comment 1 Jeremy Katz 2000-03-29 03:55:59 UTC
Created attachment 163 [details]
get rid of nasty colors

Comment 2 Trond Eivind Glomsrxd 2000-04-17 17:16:59 UTC
This isn't a bug - note that the colors are not set in /etc/pine.conf.fixed, so
you should be able to set your own colors.

Comment 3 Aleksey Nogin 2000-06-11 02:44:15 UTC
I agree that it was wrong to put these defaults in the /etc/pine.conf. Because
of this, upgrading to RH 6.2 messes with people's color setting - not nice.

Additionally, even with 
normal-foreground-color=black
normal-background-color=white
in ~/.pinerc
I still do not get white background! In kvt and xterm I get grey background and
in rxvt I get some reddish yellow. 

And even worse, there does not seem to be a way to access those settings from
pine configuration menu and it is not clear where I am supposed to look for
additional documentation on them in order to be able to "fight" them.

Comment 4 Need Real Name 2000-07-22 19:36:50 UTC
i, too, would like to emphasize that the redhat 6.2 pine default of having
colours enabled is broken.  i take issues with some of the other default
settings as well -- pine is intended to be a simple mail reader for
novice users to start with.  they're able to turn on all those features
themselves as, or IF they learn what they mean. 

my machine is primarily novice users.

and also primarily users on windows or macs whose terminal programs
defaults are *incompatible* with the default colour scheme you've selected.

please restore the pine distribution defaults.

thanks
-dean


Note You need to log in before you can comment on or make changes to this bug.