Bug 104067 - provide more informative exception msg in QGen
Summary: provide more informative exception msg in QGen
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Web Application Framework
Classification: Retired
Component: persistence   
(Show other bugs)
Version: nightly
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Archit Shah
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 99160
TreeView+ depends on / blocked
 
Reported: 2003-09-09 16:21 UTC by Vadim Nasardinov
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-09 21:14:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vadim Nasardinov 2003-09-09 16:21:21 UTC
Something along lines of p4 changelist 35761 would be
more helpful than the current exception message.  Without
this change, the exception message simply says
"unknown value in expression:  sortKey" (or something like
that).

With the change applied, the message is

Root cause: 
com.redhat.persistence.engine.rdbms.QGen$5: unknown value in expression: sortKey
query signature: com.arsdigita.categorization.Category(id, objectType,
displayName, defaultDomainClass, description, name, url, isEnabled, isAbstract,
defaultAncestors)
	at com.redhat.persistence.engine.rdbms.QGen$4.map(QGen.java:652)
	at com.redhat.persistence.common.SQLParser.identifier(SQLParser.java:770)


The enumeration of valid values helps pinpoint the error
much more quickly.

Comment 1 Archit Shah 2003-09-09 18:17:46 UTC
merged to trunk. not applicable to 6.0 branch.


Note You need to log in before you can comment on or make changes to this bug.