Bug 104075 - vsftpd configuration file misplacement
vsftpd configuration file misplacement
Status: CLOSED DUPLICATE of bug 121199
Product: Red Hat Linux
Classification: Retired
Component: vsftpd (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-09 13:02 EDT by Paul Wouters
Modified: 2014-03-16 22:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Wouters 2003-09-09 13:02:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
vsftpd when installed has its configuration file in /etc/vsftp/vsftpd.conf. No
xinetd.d/ entry was supplied with the rpm.
When using the example entry for xinetd from /usr/share/vsftpd-1.1.3
it didn't read the config file properly.

The fix is to either supply an xinet.d/vsftp entry where the location
of the configuation file is added as argument to vsftp, or the config
file needs to move back to /etc/vsftpd.conf, or one could use a symlink

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. do fresh install
2. add xinetd.d/vsftp from example dir
3. Change the banner in /etc/vsftpd/vsftpd.conf
3. restart xinetd
4. connect to ftp server and see default banner instead of your own

    

Additional info:
Comment 1 Bill Nottingham 2004-05-03 14:47:42 EDT

*** This bug has been marked as a duplicate of 121199 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.