Bug 1040943 - [REPORTS-SETUP] - remote user password is asked twice for authentication
Summary: [REPORTS-SETUP] - remote user password is asked twice for authentication
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.4.0
Assignee: Yedidyah Bar David
QA Contact: Barak Dagan
URL:
Whiteboard: integration
: 1052065 (view as bug list)
Depends On:
Blocks: 1057277 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-12-12 11:45 UTC by Barak Dagan
Modified: 2014-09-18 12:24 UTC (History)
12 users (show)

Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Bug Fix
Doc Text:
Users are no longer asked twice to provide their passwords when running ovirt-engine-reports-setup with a remote database.
Clone Of:
: 1057277 (view as bug list)
Environment:
Last Closed: 2014-06-09 15:26:46 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0602 normal SHIPPED_LIVE rhevm-reports 3.4 bug fix and enhancement update 2014-06-09 19:26:10 UTC
oVirt gerrit 23271 None None None Never

Description Barak Dagan 2013-12-12 11:45:00 UTC
Description of problem:
During installation of reports, using remote DB configuration, user is asked twice for the password :

Please choose a password for the db user: 
Warning: Weak Password.
Re-type password: 

This behaviour is generally used, when an account is created and not for authentication

Version-Release number of selected component (if applicable):
IS26

How reproducible:
100%

Steps to Reproduce:
1. install engine using remote db configuration
2. install dwh using the same remote db server
3. install reports using the same remote db server

Actual results:
1) Password is asked twice
2) There is password strength calculation

Expected results:
1) Password will be asked once

Additional info:

Comment 1 Yaniv Lavi 2013-12-18 20:50:59 UTC
I don't think this is important enough to be fixed in z stream.
Barak\Arthur, can I close on WONTFIX?


Yaniv

Comment 2 Yaniv Lavi 2013-12-18 20:51:45 UTC
(In reply to Yaniv Dary from comment #1)
> I don't think this is important enough to be fixed in z stream.
> Barak\Arthur, can I close on WONTFIX?
> 
> 
> Yaniv

Also in otopi rewrite this will longer be a issue, so will close on 3.4 as well.

Comment 3 Yedidyah Bar David 2014-01-13 09:30:15 UTC
*** Bug 1052065 has been marked as a duplicate of this bug. ***

Comment 4 Yedidyah Bar David 2014-01-13 09:32:11 UTC
It's a simple fix, I think we should do it in z stream.

Also, if passwords do not match, it fails with "global name 'dbhost' is not defined". Also not severe, but ugly.

Comment 5 Yedidyah Bar David 2014-01-14 14:41:31 UTC
23187 is for dwh, I didn't the change is ready... It will just be similar to that one.

Comment 7 Barak Dagan 2014-02-25 16:20:55 UTC
Verified on: 
ovirt-engine-3.4.0-0.11.beta3.el6.noarch

ovirt-engine-dwh-3.4.0-0.3.el6.noarch
ovirt-engine-dwh-setup-3.4.0-0.3.el6.noarch

ovirt-engine-reports-3.4.0-0.3.beta3.el6.noarch
ovirt-engine-reports-setup-3.4.0-0.3.beta3.el6.noarch

jasperreports-server-5.5.0-7.el6.noarch

Comment 8 errata-xmlrpc 2014-06-09 15:26:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0602.html


Note You need to log in before you can comment on or make changes to this bug.