Bug 104109 - Build of vnc-4.0-0.beta4.2.src.rpm fails on Redhat 9
Build of vnc-4.0-0.beta4.2.src.rpm fails on Redhat 9
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: vnc (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-09 18:31 EDT by William Hooper
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-10 05:01:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Hooper 2003-09-09 18:31:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The java compile seems to be causing issues with this release and RHL 9:

[whooper@butters whooper]$ rpm -qa gcc-java
gcc-java-3.2.2-5
[whooper@butters whooper]$ rpmbuild --rebuild vnc-4.0-0.beta4.2.src.rpm
[snip]
make[1]: Leaving directory
`/home/whooper/rpmbuild/BUILD/vnc-4.0b4-unixsrc/vncpasswd'
+ mkdir -p unix/java
+ pushd vnc-4.0b4-javasrc
~/rpmbuild/BUILD/vnc-4.0b4-unixsrc/vnc-4.0b4-javasrc
~/rpmbuild/BUILD/vnc-4.0b4-unixsrc
+ make 'JAVAC=gcj -C'
rm -f `find . -name '*.class' -print`
gcj -C -d . rdr/EndOfStream.java rdr/Exception.java rdr/IOException.java
rdr/InStream.java rdr/JavaInStream.java rdr/JavaOutStream.java
rdr/MemInStream.java rdr/MemOutStream.java rdr/OutStream.java
rdr/ZlibInStream.java rfb/AliasParameter.java rfb/AuthFailureException.java
rfb/BoolParameter.java rfb/CConnection.java rfb/CMsgHandler.java
rfb/CMsgReader.java rfb/CMsgReaderV3.java rfb/CMsgWriter.java
rfb/CMsgWriterV3.java rfb/CSecurity.java rfb/CSecurityNone.java
rfb/CSecurityVncAuth.java rfb/Configuration.java rfb/ConnFailedException.java
rfb/ConnParams.java rfb/Cursor.java rfb/Decoder.java rfb/DesCipher.java
rfb/Encoder.java rfb/Encodings.java rfb/Exception.java rfb/Hextile.java
rfb/HextileDecoder.java rfb/Hostname.java rfb/IntParameter.java rfb/Keysyms.java
rfb/LogWriter.java rfb/ManagedPixelBuffer.java rfb/MsgTypes.java
rfb/PasswdGetter.java rfb/PixelBuffer.java rfb/PixelFormat.java
rfb/RREDecoder.java rfb/RawDecoder.java rfb/SecTypes.java
rfb/StringParameter.java rfb/UnicodeToKeysym.java rfb/VncAuth.java
rfb/VoidParameter.java rfb/ZRLEDecoder.java vncviewer/AboutDialog.java
vncviewer/CConn.java vncviewer/ClipboardDialog.java vncviewer/DesktopWindow.java
vncviewer/Dialog.java vncviewer/F8Menu.java vncviewer/InfoDialog.java
vncviewer/MessageBox.java vncviewer/OptionsDialog.java
vncviewer/OptionsDialogCallback.java vncviewer/PasswdDialog.java
vncviewer/PixelBufferImage.java vncviewer/ServerDialog.java vncviewer/VNCViewer.java
vncviewer/OptionsDialog.java:119: Type `GridBagLayout' not found in declaration
of field `mainGB'.
     GridBagLayout mainGB;
     ^
vncviewer/OptionsDialog.java:121: Type `GridBagLayout' not found in declaration
of field `panelGB'.
     GridBagLayout panelGB;
     ^
2 errors
make: *** [vncviewer.jar] Error 1
error: Bad exit status from /home/whooper/rpmbuild/tmp/rpm-tmp.6346 (%build)
 
 
RPM build errors:
    Bad exit status from /home/whooper/rpmbuild/tmp/rpm-tmp.6346 (%build)
[whooper@butters SRPMS]$


Version-Release number of selected component (if applicable):
vnc-4.0-0.beta4.2.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. Attempt to rebuild the src.rpm.    

Actual Results:  Build fails on Java portion.

Expected Results:  Build completes successfully.

Additional info:

On this same system rebuilding vnc-4.0-0.beta3.5.1.src.rpm works fine.
Comment 1 Tim Waugh 2003-09-10 05:01:49 EDT
3.5.1 wasn't building the java byte code.  Guess you need to update gcc from
rawhide, or munge the spec file so that the java bits are omitted.

It isn't really worth me putting in a work-around for this, because pretty soon
vnc won't build without the very latest XFree86-sdk package from rawhide anyway.
 Sorry. :-(
Comment 2 William Hooper 2003-09-10 20:44:58 EDT
The old version not building the bytecode explains the difference.  I just use 
your RPMs because they build directly unlike the RealVNC one.

I figured at some point you were going have to do something about the X tree 
rather than including it all.  Oh well, I've been meaning to get a rawhide 
machine going :-)
Comment 3 Tim Waugh 2003-09-11 04:12:13 EDT
You could just take out the bits of the spec file that have to do with the java
stuff.  It turns out that building against the XFree86-sdk package is further
away than I had hoped, so I might be able to make this easier in due course.

Note You need to log in before you can comment on or make changes to this bug.