Bug 104111 - crashes occur when attempting to activate/deactivate modem while using Network tool.
crashes occur when attempting to activate/deactivate modem while using Networ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: rcn-modem
  Show dependency treegraph
 
Reported: 2003-09-09 19:24 EDT by solomon
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version: system-config-network-1.3.26-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-20 08:10:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description solomon 2003-09-09 19:24:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The Network tool crashed and then dumped this to a file and said I should report it:

Component: redhat-config-network
Version: 1.2.0
Summary: TB
/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py:352:hydrateDevices:AttributeError:
'NoneType' object has no attribute 'clear'
Traceback (most recent call last):
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 505, in updateDevicelist
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 352, in hydrateDevices
AttributeError: 'NoneType' object has no attribute 'clear'


/*****************************************************/

This was another buginfo dump that happened minutes after. I'm putting them in
the same bug report because they seem related (they both occur when attempting
to activate/deactivate the dial-up modem). I should also mention that I still
cannot activate dial-up from Network tool. It can only be done from kppp, and
even then, all the panels freeze, unless I launch kppp from the command-line.

Component: redhat-config-network
Version: 1.2.0
Summary: TB
/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py:352:hydrateDevices:AttributeError:
'NoneType' object has no attribute 'clear'
Traceback (most recent call last):
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 808, in on_deviceDeactivateButton_clicked
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 505, in updateDevicelist
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 352, in hydrateDevices
AttributeError: 'NoneType' object has no attribute 'clear'

Local variables in innermost frame:
profilelist: [<rhpl.genClass.Profile instance at 0x868bb8c>]
devsel: <netconfpkg.plugins.NCDevModem.DevModem instance at 0x867a694>
clist: None
devicelist: {'_parent': None, '_dead': 0, '_attributes': {'Device': {'FLAGS':
[], 'TYPE': 'LIST', 'NAME': 'Device'}, 'SELF': {'FLAGS': ['ANONYMOUS'], 'NAME':
'DeviceList', 'PARENT': None, 'CHILDKEYS': ['Device'], 'install_func': <function
GenClassAList_get_install_funcs at 0x8344554>, 'TYPE': 'LIST'}}, 'changed': 0,
'data': [<netconfpkg.plugins.NCDevEthernet.DevEthernet instance at 0x8139494>,
<netconfpkg.plugins.NCDevModem.DevModem instance at 0x867a694>], 'data_bak':
[<netconfpkg.plugins.NCDevEthernet.DevEthernet instance at 0x8139494>,
<netconfpkg.plugins.NCDevModem.DevModem instance at 0x867a694>]}
self: <netconfpkg.gui.maindialog.mainDialog instance at 0x8613564>
activedevicelist: ['lo']


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Attempt to activate dial-up modem connection with Network tool
(Kmenu->SystemSettings->Network)
2. Select dial-up Modem device, click Activate... wait several minutes while
nothing happens, close window and attempt to Deactivate, wait more minutes,
close Network tool.
3. Watch to see if bug happens (does not always happen)
    

Actual Results:  RedHat told me a bug had occured and I should report it (and I
have done so. the info that it dumped is in the Description of this report).

Expected Results:  I don't know. I've never had Network tool work for me.

Additional info:
Comment 1 Harald Hoyer 2003-09-10 08:53:14 EDT
Please try the erratum
http://rhn.redhat.com/errata/RHBA-2003-183.html
and report, if your problem still exists.
Thx and sorry for the inconvenience..
Comment 2 solomon 2003-09-12 16:49:15 EDT
Well, I tried this, and I'm not even sure the package installed properly. I got the following: 
 
 
[root@localhost Desktop]# rpm -Fvh redhat-config-network-1.2.15-1.src.rpm 
warning: redhat-config-network-1.2.15-1.src.rpm: V3 DSA signature: NOKEY, key ID db42a60      
e 
   1:redhat-config-network  ########################################### [100%] 
 
 
 
 
It looks like it tried to install... but something seems to have gone wrong. 
either way, the Network tool no longer crashes, and does not give any crash data (it hasn't yet) 
but it still won't create a dial-up connection to the internet. When I set the dial-mode to 'auto', 
Network tool claims my modem connection is Active after I push the Activate button, but there 
is no dialing sound and pings fail. When dial mode is set to manual, it spends forever 
attempting to activate, and then decides that it can't. 
 I have to use kppp (which seems to have some issues with being launched from the Panel, 
but I'll take that matter up with KDE) to dial the modem. 
Comment 3 Harald Hoyer 2003-09-15 04:31:05 EDT
Did you update rhpl as well?
Comment 4 solomon 2003-09-15 11:51:30 EDT
I wasn't aware it needed updating. Where can the update be found?
Comment 5 Harald Hoyer 2003-09-16 06:35:42 EDT
here: http://rhn.redhat.com/errata/RHBA-2003-183.html
Comment 6 solomon 2003-10-15 23:15:29 EDT
sorry it took me so long, been quite busy... 
 
well I just got around to running up2date, and updated EVERYTHING! 
now, I STILL cannot dial the dial-up modem from Network tool, when I try, the 
program hangs, then my network (ethernet) connection dies too (ping returns 
"network not found" or something similar). I'm not sure why. When I do this am 
I telling it to replace my ethernet connection with a dial-up connection 
(which never happens anyway)? I think I can still dial using kppp. 
 
It is no longer a major issue since I now have a DSL connection through a LAN, 
but there are still occations where I need a dial-up connection. 
 
If there's a log file you'd like me to look for and attach I can do that too, 
if it might help (I just don't know which one you'd want) 

Note You need to log in before you can comment on or make changes to this bug.