Bug 104131 - mozilla erased my bookmarks file when run as root
mozilla erased my bookmarks file when run as root
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-10 08:15 EDT by Jonathan Kamens
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-28 09:38:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 251692 None None None Never

  None (edit)
Description Jonathan Kamens 2003-09-10 08:15:41 EDT
Run mozilla as yourself. Create a bookmark.  Exit.  Run "su -m root -c
/bin/bash".    Run mozilla.  Exit.  Exit from the shell.  Run mozilla as
yourself again.  Try to use your bookmarks; note that they are empty.

I *think* that's sufficient; you may actually need to view the bookmarks menu
when running as root to make mozilla blow them away, but I'm not certain about that.

I'm using mozilla-1.4-12.

This is a bad bug, since it results in data loss.
Comment 1 Christopher Blizzard 2003-10-08 13:22:05 EDT
-m fails to reset the environment.  I'll bet you're writing out the bookmarks
file as root and then the user can't read it.
Comment 2 Jonathan Kamens 2003-10-08 13:24:23 EDT
I know what -m does.  You'd lose that bet.  I checked after running mozilla as 
root and the bookmarks file was *gone*, not just unreadable.

Besides, even if you were right, that's still a bug -- if Mozilla can't read 
the bookmarks file, it should complain, not silently delete the unreadable file.
Comment 3 Bill Nottingham 2006-08-07 21:42:14 EDT
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.
Comment 4 Jonathan Kamens 2006-08-10 04:30:55 EDT
Still a problem in mozilla-1.7.12-5 (i.e., fc5).
Comment 5 Matěj Cepl 2007-07-18 13:29:45 EDT
Fedora Core 5 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 6 Jonathan Kamens 2007-07-18 13:38:00 EDT
Still a bug in firefox-2.0.0.4-3.fc8.

<frustrated>
Amazing that it hasn't been fixed in almost four years.  Perhaps you could 
consider upstreaming it rather than just letting it stagnate here and making me 
reverify it every so often?  Or at least tell me definitively that you're not 
going to fix it, and I'll report it into the firefox bug-tracking system myself?
</frustrated>
Comment 7 Matěj Cepl 2007-08-28 09:38:56 EDT
I am really sorry, and yes you are right, we should upstreamed this couple of
years ago :-(.

However, upstream situation is not good --
https://bugzilla.mozilla.org/show_bug.cgi?id=205053 good closed as WONTFIX (I
can hardly believe this myself, but it did) and
https://bugzilla.mozilla.org/show_bug.cgi?id=251456 is already three years old
(yes, slightly younger, than this one ;-)) and it doesn't seem to go anywhere.
Firefox bug is https://bugzilla.mozilla.org/show_bug.cgi?id=251692 and three
years old as well.

Nevertheless, I am afraid that I have to upstream this bug already. Whole this
situation is messy, but it should be probably really resolved upstream. We don't
have time and resources to keep fork of mozilla.

Note You need to log in before you can comment on or make changes to this bug.