Bug 104132 - BebopApplicationServlet doesn't support output=xml , developer support stages, etc
BebopApplicationServlet doesn't support output=xml , developer support stages...
Status: CLOSED RAWHIDE
Product: Red Hat Web Application Framework
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-10 08:38 EDT by Daniel Berrange
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 08:44:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2003-09-10 08:38:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
The BebopApplicationServlet class uses its own custom XSLT transfomration code
instead of the standard PresentationManager APIs. As a results if your app uses
this class for serving requests there will be a number of problems:

* ?output=xml to view RAW XML document
* ?output=xsl to download XSLT files as JAR
* The XSLT 'encoding' output property is not set
* The character set encoding on the Writer is never set
* Setting of default cache control headers

To elminate these problems & achieve consistency across all applications in the
system BebopApplicationServlet should be changed to use the standard
presentation APIs & implementations.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Uncomment getServletPath in Forum.java
2. Redeploy code
3. Try requesting /forum/index.jsp?output=xml
    

Actual Results:  Continues with normal display

Expected Results:  Shows raw XML

Additional info:
Comment 1 Daniel Berrange 2003-09-26 14:57:15 EDT
I fixed this in 36402 since it is really killing developers trying to write
applications with the new servlets & it is unlikely that the refactoring the
stuff in PageTransformer will happen in the near future.

Note You need to log in before you can comment on or make changes to this bug.