Bug 104137 - Kickstart unable to lock NIC media type
Kickstart unable to lock NIC media type
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-10 09:59 EDT by Need Real Name
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 23:26:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-09-10 09:59:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705; .NET CLR 1.1.4322)

Description of problem:
I am trying to develop a kickstart deployment process for the Dell poweredge 
650, the IBM x335, and the Hp/Compaq dl360 g3.  I have created a Custom 
bootnet.img that supports the e1000 and bcm5700 NIC's, and if I leave the 
network switch set to auto negotiate, everything works fine.  Unfortunantely, 
all of the
switch port will be locked and therfore I need to be able to lock the media 
type to 100 / full in the kickstart script.  I have tried several variations of 
the "device"
command in the kickstart script without any luck.  Here are some of the 
kickstart commands that I have tried without success - 
device eth e1000 --opts "Speed=100, Duplex=2"  
and 
device eth bcm5700 --opts "speed 100 duplex full autoneg off"

None off the kickstart commands I have used work.

Thanks
Tom


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create a bootnet.img to support the e1000 and BCM5700 gig NIC's
2.configure the ks.cfg for a network build.
3.
    

Actual Results:  I can tell via the ctl-alt f3 and f3 that the adapter is auto 
negotiating rather than being locked at the requested media type.

Expected Results:  hopefully it would have been locked at 100 / full

Additional info:
Comment 1 Phil Knirsch 2003-12-15 04:01:01 EST
Reassigning to anaconda, seems more appropriate than kernelcfg (which
was a GUI tool to configure /etc/modules.conf ages ago). :-)

Read ya, Phil
Comment 2 Jeremy Katz 2004-10-04 23:26:55 EDT
This can be done in newer releases with ethtool opts on the install
command line or in the ks.cfg

Note You need to log in before you can comment on or make changes to this bug.