Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1041558 - Filter out rootpw from anaconda reports
Filter out rootpw from anaconda reports
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
21
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1168523
  Show dependency treegraph
 
Reported: 2013-12-12 12:18 EST by Orion Poplawski
Modified: 2016-11-30 19:45 EST (History)
12 users (show)

See Also:
Fixed In Version: libreport-2.3.0-5.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1168523 (view as bug list)
Environment:
Last Closed: 2014-12-13 04:55:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2013-12-12 12:18:52 EST
Description of problem:

It would be good if abrt filtered out "rootpw" lines from anaconda reports.  I know this is in the ks.cfg and the traceback files, perhaps others.
Comment 1 Orion Poplawski 2014-11-04 18:48:44 EST
I think this is fairly important.  How can I help?
Comment 2 Jakub Filak 2014-11-05 01:33:55 EST
It is already possible to highlight such lines, but auto-removing is not implemented yet. Would the highlighting be an acceptable solution to you?
Comment 3 Orion Poplawski 2014-11-05 10:46:10 EST
It's better than nothing, but it should be auto-removed, especially since the text mode reporter makes it quite hard to find.
Comment 4 Jakub Filak 2014-11-06 02:33:31 EST
Ah, I forgot on the text mode reporter. Hence I am adding a simple auto-remove utility for Anaconda reports in the following pull request:
https://github.com/abrt/libreport/pull/301

The pull request also enables highlighting of "rootpw" lines in the GUI reporter.

Vratislav, could you please take a look at that pull request?
Comment 5 Vratislav Podzimek 2014-11-06 03:12:41 EST
(In reply to Jakub Filak from comment #4)
> Ah, I forgot on the text mode reporter. Hence I am adding a simple
> auto-remove utility for Anaconda reports in the following pull request:
> https://github.com/abrt/libreport/pull/301
Looks good to me.
Comment 6 Jakub Filak 2014-11-26 05:06:51 EST
I opened another pull request for a patch making libreport aware of anaconda-tb:
https://github.com/abrt/libreport/pull/305

libreport cannot highlight all forbidden words in that file because the file contains too many false positives.
Comment 7 Orion Poplawski 2014-11-26 10:18:33 EST
Would be nice to get this into F21 Final.
Comment 8 Scott Suehle 2014-11-26 15:15:47 EST
Discussed at today's blocker review meeting [1]. Accepted as a AcceptedFreezeException. A fix for this would be considered during freeze.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2014-11-12/
Comment 9 Fedora Update System 2014-11-28 09:08:14 EST
libreport-2.3.0-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/libreport-2.3.0-5.fc21
Comment 10 Fedora Update System 2014-11-29 15:59:39 EST
Package libreport-2.3.0-5.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreport-2.3.0-5.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15939/libreport-2.3.0-5.fc21
then log in and leave karma (feedback).
Comment 11 Jakub Filak 2014-12-03 11:17:13 EST
(In reply to Scott Suehle from comment #8)
> Discussed at today's blocker review meeting [1]. Accepted as a
> AcceptedFreezeException. A fix for this would be considered during freeze.
> 
> [1] http://meetbot.fedoraproject.org/fedora-blocker-review/2014-11-12/

I can find this bug report in the log. Has this bug exception or not?
Comment 12 Adam Williamson 2014-12-05 14:43:39 EST
It did, but we exercised discretion not to put it in the final week composes as by that point we're really in 'hair-on-fire changes only' mode. Sorry about that!
Comment 13 Adam Williamson 2014-12-05 14:44:43 EST
21 is done, cleaning blocker process metadata.
Comment 14 Fedora Update System 2014-12-13 04:55:31 EST
libreport-2.3.0-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.