Bug 10416 - after bringing dhcp (pump) configured interface down it won't come back up
after bringing dhcp (pump) configured interface down it won't come back up
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-29 13:39 EST by Chris
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-23 11:16:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris 2000-03-29 13:39:42 EST
If the system has two ethernet interfaces, one configured with dhcp using
pump, connected to a cable modem, and the other one configured manually for
the local network, if the interfaces are brought down e.g. by changing
runlevel, the dhcp configured interface will not be able to obtain a new ip
when the runlevel is changed to something where the network is enabled
again. This is because the second ethernet interface retains it's IP
address even though it's down. When pump tries to get an IP from dhcp, it
uses the IP of the second card as the source address for the request, and
as a result the cable modem filters out the request, and pump never gets a
reply. My proposed fix is to change line 46 of /sbin/ifdown to "ifconfig
${DEVICE} 0.0.0.0 down" (the change is the added 0.0.0.0) so the ip of the
second interface will get removed from the interface. Then pump will send
out requests from an IP address that is accepted by the cable modem.
Comment 1 Bill Nottingham 2000-04-10 14:34:59 EDT
This sounds more like a problem with pump; it shouldn't be sending
the requests like that.
Comment 2 Jari Turkia 2000-04-23 11:16:59 EDT
In the pump-0.7.8 source code, function pumpDhcpRun there is program code to
reset the client address to all zero. Obviously this code has no effect as the
outgoing IP address is inserted by kernel. The socket is standard datagram
socket, not a raw one.

Also having similar setup myself as most of the people here complaining about
pump not working on RH6.2, I also run into problem where DHCPc request was sent
from a NIC which was _not_ specified on the pump command line. It looked like
kernel made a decision to output the broadcast packet (255.255.255.255:67) from
the other NIC.

There seem to be some major problems with the kernel, not the pump itself.
Comment 3 Erik Troan 2000-08-05 09:21:40 EDT
This should be fixed in pump 0.8, available from ftp://people.redhat.com/ewt --
please try
it.
Comment 4 Jari Turkia 2000-08-06 02:00:04 EDT
I can confirm this _not_ to work. I built the pump 0.8 from the sources given,
but it does not seem to help. My test was simple: ifdown to the interface using
DHCP and it won't ifup. I had to ifdown the other interface using static address
and manually specify it to have address 0.0.0.0 and after that the DHCP i-face
got up. To me it looks like nothing changed.

Note You need to log in before you can comment on or make changes to this bug.