Bug 10418 - SCSI driver modual aic7xxx crashes on boot floppy
SCSI driver modual aic7xxx crashes on boot floppy
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-29 14:19 EST by mark
Modified: 2008-05-01 11:37 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-20 07:27:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mark 2000-03-29 14:19:08 EST
When attempting to install RedHat 6.2 on a Integraph TD3, the
system has a kernal panic on the selection of the SCSI CDROM
driver for the aic7xxx.  This driver worked great in the 6.1
driver.

The aic7xxx module is part of the AHA-2740 series.

The versions of RedHat are the downloaded iso images

The boot image images/boot.img was written to a 1.44 floppy.

The message returned is

  Kernel panic: aic7xxx: unrecoverable BRKADRINT
  In swapper task - not syncing

The system halts at that point.

Going back to the 6.1.92 beta software, it does not have that problem.
Comment 1 necrotech 2000-03-30 21:28:59 EST
I have had this exact same thing happen to me, only it's not limited to the
floppy install. It happens over the network as well (had the CD mounted on
another server and shared via FTP).

I *cannot* install RedHat Linux 6.2 on my HP Netserver LM/60 because of this
issue. I'll have to stick with 6.0 or 6.1.

I thought it might have something to do with the fact that this is an EISA-bus
system - no PCI.
Comment 2 Doug Ledford 2000-03-31 13:43:59 EST
The actual problem is that the 2742 EISA cards and the 2842 VLB cards have the
7770 chipset and there is a problem in the sequencer on those cards.  This will
require a driver update disk to fix.  Since the 6.1 product release we have had
the ability to give out an updated driver disk that could be used during the
install to get around these issues.  You can read about the driver update disks
on my web site at people.redhat.com/dledford  However, the 5.1.28 version of the
aic7xxx driver does not yet solve this problem.  It will only be solved after
the 5.1.29 version of the aic7xxx driver is release.  I expect that to be
sometime in the next week.
Comment 3 Anonymous 2000-04-20 13:52:59 EDT
I could upgrade 6.2 on my all scsi system. even mount my current ext2 drive
using the bash screen.

...but when I tried to boot the new system; it has a kernel panic trying to
mount the / drive.

I've had RH since 5.0 and I've ever had this problem before...... ;-(
Comment 4 Carl Kristian Eriksen 2000-05-01 10:13:59 EDT
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=10677, seems related to
this, and <a
href="http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=10467">10467</a> is
the exact same.

I have tried The aic7xxx version 5.1.29 driver update disk for Red Hat Linux
6.2 from Doug's aic7xxx Page ( http://people.redhat.com/dledford/aic7xxx.html )
but no luck there either...

During "Loading aic7xxx driver..." the message comes along:
  Kernel panic: aic7xxx: unrecoverable BRKADRINT.
  In swapper task - not syncing

Both the the original 6.0 image, and the 6.1 boot image works fine.
Comment 5 Carl Kristian Eriksen 2000-05-01 10:29:59 EDT
I forgot to mention that I have an onboard dual AHA2740 adapter.
And that the aic7xxx 5.1.29 driver update disk from Doug's aic7xxx Page didn't
help.
Comment 6 mark.sibbald 2000-05-19 12:50:59 EDT
I have also tried the 5.1.29 version of the aic7xxx driver, and it does not
work for me on my HP Netserver LC with the embedded AIC-7770 SCSI controller.
Comment 7 Jaroslaw Sosnicki 2000-06-21 20:05:03 EDT
I am having problem with aic-7xxx driver on my Intel pr440fx mother boards as 
well. It uses aic-7880 chips set.
My motherboard works with Windows 2000 Professional installed on second drive.
Comment 8 Doug Ledford 2000-06-22 20:25:48 EDT
The current aic7xxx driver version is 5.1.31 and is available on my web site (as
noted earlier in the comments).  Please try that and then if there is still a
problem, re-open this bug.  The 5.1.31 driver is known to solve the BRKADRINT
problems that we have found and also fixes a few other problems.
Comment 9 necrotech 2000-07-04 12:01:12 EDT
5.1.31, unfortunately did NOT solve the problems on my HP Netserver LM/60

I downloaded the driver disk provided on 
http://people.redhat.com/dledford/aic7xxx.html, started install and inserted 
driver disk when prompted, and same bug occurs during installation:

"kernel panic: aic7xxx: unrecoverable BRKADRINT
In swapper task - not syncing"

This is an onboard EISA controller. I do have the option of going back to 6.0, 
or perhaps 6.1 (haven't checked, but I think it works), but RedHat 6.2 still is 
a no go on that machine.

Can we re-open this bug?
Comment 10 james.wilde 2000-07-05 11:38:31 EDT
Fujitsu/ICL H532i Teamserver here with AIC7870 on-board chips.  Version 5.1.31 
has not solved my problem either.

Whichever method I use to install aic7xxx drivers the system hangs with the 
message Loading aic7xxx drivers.  I've tried the standard method, expert method 
and linux dd method.  Freebsd installs without a qualm, as does NT.

I've just updated the AMI bios to v.1.00.10BGO which also updated the SCSI bios 
to, I think, 1.16.

Hope you'll keep this bug alive.

James
Comment 11 trpjr 2000-07-05 21:20:39 EDT
I have a netserver 5/66 LC that is giving the same problem mentioned above.  
Specifically, I get "kernel panic: aic7xxx: unrecoverable BRKADRINT In swapper 
task - not syncing" when trying to install.  I have also downloaded the latest 
adaptec driver and ... no dice!  Please reopen this bug.

TP  
Comment 12 stormkartr 2000-07-14 11:46:02 EDT
This is definitely a problem. I am using an Adaptec-2740 EISA card with an AMI
Titan-II Motherboard and I am getting: 
      "Kernal Panic: aic7xxx: unrecoverable BRKADRINT.
       In swapper task - not syncing"
then the system locks at that point.

I downloaded the dd.img file for RedHat 6.2 from people.redhat.com/dledford and
though the new driver appears to load, after thesecond stage file loads the
install dies with:
	"error 2 reading header: Success
         cpio failed on (null):(internal)"

then stops the install.
Comment 13 james.wilde 2000-07-17 03:59:01 EDT
Further to my earlier note, I see that many people with this problem 
have 'solved' it by using earlier versions.  I have managed to get my hands on 
a copy of 6.1 which does NOT work on my Fujitsu H532i machine.  I have now 
tried several different distributions of Linux - a bit pointless really as I 
finally realised that they are all using the same kernel - without success.  In 
addition to FreeBSD and NT, I can load Solaris 7 x86, so, wherever the problem 
lies, it is a factor of Linux's ability to handle these adapters.
Comment 14 Michael Owen 2000-07-17 09:07:28 EDT
I think I have to back up James Wilde here - I'm running with an on-board Adaptec 7896 chipset (Intel L440GX+) and none of the old versions I've tried 
have helped me thus far. Win2K seems to work fine for me, but none of the Linux distros (incl. RedHat 6.2) get past the loading of the aic7xxx driver.
Comment 15 Jim Johnson 2000-07-18 07:53:56 EDT
I've tried the new driver 5.1.31 with no regard.  I have a HP netserver LH 90 
with an Adaptec 2740 EISA SCSI card with the same errors as above.  Four 
distributions of Linux have failed.  Linux-Mandrake, Red Hat, Slackware, 
FreeBSD.  

(SCSI0) BRKADRINT error (0x2):
        Illegal Sequencer Address referenced
(SCSI0) SEQADDR=0x1
Kernel panic: aic7xxx: unrecoverable BRKADRINT
In swapper task-not sycing.
Comment 16 Jim Johnson 2000-07-18 19:12:34 EDT
Please disregard my previous email.  IGIT GALOOT is the final outcome.  I failed to read the fine print on Doug's page.  The part where it says to use the driver at the bottom of the list named updated aic7xxx driver.  Im sending this from my RH 6.2 box, and everything went fine.

Sorry Doug,
Great Job!!!!
Comment 17 james.wilde 2000-07-20 08:19:39 EDT
Hopefully my final update in this thread.  Please see earlier messages for my 
machine spec.  It is a Fujitsu H532i.  The Adaptec bios is 1.26sP8.

I have not had any luck with Doug's drivers.  However, working on a tip from 
Knut Stormkartr I have discovered that RH 5.0 and 5.1 but not 5.2 will 
successfully install.  I have now installed from RH 5.0 since I have no 5.1 CD 
and haven't found an .iso image yet on the net.

So now I have a working Linux machine running the 2.0.32 kernel.  Now I'm going 
to go away and work out how to upgrade to RH 6.2 without breaking anything!

Good luck to everyone else.
Comment 18 Lap Kiu Lo 2000-08-14 12:01:52 EDT
I am currentlty using Redhat 6.1, the aic7xxx driver worked great for me. Recently, I upgraded and compiled the kernel from 2.2.12 to 2.2.16, I could 
make the system to boot up but I have the following error message "Scsi bus is being reset for host 0 channel 0. Aborting command due to timeout". 
What is that mean? Is it related to the issue of the aic7xxx driver? The following info may be useful for people who want to solve this problem for me

OS             : Redhat 6.1
Motherboard: Asus P2BDS
Scsi            : Adaptec. AIC 7890 & AIC 3860

Bernard
Comment 19 Need Real Name 2000-09-15 16:26:55 EDT
I dont think this bug has been solved yet.
I tried the new driver 5.1.31 on my FIC VIP-I02 motherboard with
an AHA-2940 PCI card Firmare 1.11 and I still have the kernel panic problem :-(

Did anyone try to upgrade the 2940' bios to 1.16 yet???

Best regards Chris
Comment 20 Lembit 2000-09-20 07:27:08 EDT
I've tried to install RedHat 6.1 from CD to Intel ISP2150 2xPIII 550 processors:
Installer started to load aic7xxx driver and that was the end of it.
Ctrl-Alt-F2 etc did not work as well. At the same time RedHat 6.2 installed 
perfectly. On internal application reason I still need to run 6.1 on this 
server but how ?

Comment 21 Need Real Name 2001-01-02 11:56:28 EST
Recently tried to upgrade my companies Linux server running the 2.2.5-22 kernel 
with the 2.2.16-3 kernel RPM's from Redhat.  The upgrade went fine until I 
tried to reboot and got the error message:

"Scsi bus is being reset for host 0 channel 0. Aborting command due to 
timeout". 

When I go back to the old kernel, everything seems to work.  I had considered 
trying to use some of the newer drivers, but those don't seem to work, either.  
Any ideas?

Thanks,

Joe
Comment 22 Need Real Name 2001-03-02 21:27:45 EST
I'm unable to install 6.2 linux. System configuration is as follows:

Tyan KT
AMD 750 Athlon
Adaptec 39160
two ultra 160 scsi disks
3-256mb memory modules

System will not reboot after fresh install, including most recent driver from website. I believe the motherboard in the
problem. Any help wil be appreciated
Comment 23 Need Real Name 2001-03-08 04:49:13 EST
F.Y.I.

It sounds like this problem is not forgotten after all.

//Thomas

>Hi,
>
>I have tried to download the AIC7xxx device drivers from your free bsd =
>site. I download to a Windows 98 machine why I use rawrite to move the =
>driver to a floppy. It fails however, giving a "bad sector" error =
>message.

The floppy images for the 6.1.5 driver are corrupt.  I'm working on
6.1.6 of the driver and will update the images when it is released.
I expect that to happen before the end of this week.

--
Justin
Comment 24 Need Real Name 2001-03-19 12:18:38 EST
I have the same problem, when I connect a CD on the SE connector.
I tried every drivers on all sites supposed to resolve the problem but it's the
same.
My card is an adaptec 29160N on a ASUS card and with an athlon 1GHz.
Comment 25 Need Real Name 2001-05-05 19:25:25 EDT
Good thing I am not alone...
I have a MSI 694D Pro Dual Pentium 3 800Mhz, and an Adaptec 29160N with
2 SCSI HD, and 2 SCSI CD & CDR.
All the Aic7xxx drivers from Releases 5.2 & 6.2 & 7.0 & 7.1 got the problem.
It hangs when starting to read the CDROM packages. In 7.1 it says SCSI bus is 
being reset for host 0 channel 1. Aborting command due to 
timeout. Trying harder.
I have tried all different configurations in the SCSI bios setup (incl. wide 
negotiation - disabled) I even disabled the bios, but with no luck......

Geir S
Please help. I'm about to give up on linux

Comment 26 Arjan van de Ven 2001-05-06 05:42:02 EDT
gdyrs@online.no:
is this during install? Can you try the alternate aic7xxx driver we ship?
(and please open a separate bug for this)
Comment 27 Need Real Name 2001-05-06 08:34:17 EDT
This is happening during the installation with the blue screen.
I have also tried with the alternate driver in the /images folder.
It gives me the option of trying a new experimental driver aic7xxx.
What happen afterwords is:
SCSI bus is being reset for host 1 channel 0
SCSI host 1 channel 0 reset (pid 0) timed out - trying harder

These two lines is being repeated every second, and the CDROM's gives
clicking sound.
Could there be some problem for the driver with handling a SE- and a
LVD segment at the same time?

Note You need to log in before you can comment on or make changes to this bug.