This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 104215 - anaconda broke my driver disk
anaconda broke my driver disk
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: anaconda (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-11 06:59 EDT by Tim Waugh
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-29 16:21:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
mkbpckdd script (1.40 KB, text/plain)
2003-09-11 07:00 EDT, Tim Waugh
no flags Details

  None (edit)
Description Tim Waugh 2003-09-11 06:59:54 EDT
Description of problem:
My driver disk, which was created in the same way as one that worked for Red Hat
Linux 8.0, has been broken since Red Hat Linux 9.  It is for installing from
parallel port CD-ROM drives.

Version-Release number of selected component (if applicable):
Red Hat Linux 9, current Severn betas.

How reproducible:
100%

Steps to Reproduce:
1. Boot from bootdisk.img with 'linux dd hdc=none hdd=none'
2. Insert bpckdd.img when prompted
3. Try to get as far as a mount attempt from /dev/pcd0
    
Actual results:
Fails miserably because anaconda got dumber.

I'll attach the script I use to create bpckdd.img.  Briefly though, it creates this:

--> modinfo
Version 0
pcd
        cdrom
        "Parallel-port IDE CDROM"
<--

--> modules.dep
aten: paride
bpck: paride
bpck6: paride
comm: paride
dstr: paride
epat: paride
epia: paride
fit2: paride
fit3: paride
friq: paride
frpw: paride
kbic: paride
ktti: paride
on20: paride
on26: paride
paride: parport_pc parport_serial
pcd: aten bpck bpck6 comm dstr epat epia fit2 fit3 friq frpw kbic ktti on20
on26parport_pc: parport
parport_serial: parport_pc
<--

modules.cgz
pcitable (empty)
rhdd-6.1 (empty)


The problem boils down to: how does anaconda expect to know what device node to
attempt to mount if it is a parallel port device?

IMHO, if all else fails it should take the name of the driver (pcd) and attempt
to create /dev/pcd0 (which it knows the major/minor for), and try that.
Comment 1 Tim Waugh 2003-09-11 07:00:36 EDT
Created attachment 94409 [details]
mkbpckdd script
Comment 2 Jeremy Katz 2003-09-25 19:23:59 EDT
We don't at all support using the parallel port cdrom drive stuff anymore and a
lot of the random probing that would allow us to find these has now been pulled
while cleaning up cruft.
Comment 3 Tim Waugh 2003-09-29 08:28:43 EDT
No, you don't understand: I have created my own, non-supported, driver disk for
providing the drivers.

Or is it explicit Red Hat policy to actively *prevent* such third-party driver
disks from working now?
Comment 4 Jeremy Katz 2003-09-29 16:21:19 EDT
We allow third-party driver disks for things that are, eg, SCSI, but that
doesn't generalize out to parallel port cd-rom drives which live in their own
universe in a lot of ways (especially wrt probing and device nodes).

Note You need to log in before you can comment on or make changes to this bug.