Bug 104246 - (NET E1000) dhcp fails during installation w/ Compaq NC6136 Gigabit NIC, works after install
(NET E1000) dhcp fails during installation w/ Compaq NC6136 Gigabit NIC, work...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-11 14:23 EDT by Michael J. Carter
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-14 12:36:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'sysreport' output (382.54 KB, application/octet-stream)
2005-02-28 12:27 EST, Michael J. Carter
no flags Details

  None (edit)
Description Michael J. Carter 2003-09-11 14:23:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030807

Description of problem:
I've got two HP DL360G3 servers that both exhibit this behavior.
Installer fails to get ethernet address (and kickstart file) from dhcp server.
If install is completed manually, the ethernet interface comes up properly via
dhcp on first boot.

The ethernet card is:

06:01.0 Ethernet controller: Intel Corp. 82543GC Gigabit Ethernet Controller
(Fiber) (rev 02)
        Subsystem: Compaq Computer Corporation NC6136 Gigabit Server Adapter
        Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 11
        Memory at f7fe0000 (32-bit, non-prefetchable) [size=128K]
        Memory at f7fd0000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: [dc] Power Management version 2

Is the e1000 driver in the installer different from the one in the kernel rpm
that gets installed on the system?



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Taroon-beta2 on HP GL380G3 w/ HP NC6136 fiber card.
2. Choose 'Get IP automatically' in installer.
3.
    

Actual Results:  Installer fails to get IP address. This also causes kickstart
installs where the dhcp server defines the location of the .ks file to fail.

Expected Results:  Bliss.

Additional info:

Both on-board ethernet controllers are turned off in the BIOS. Only the PCI
ethernet card detailed above is active.
Comment 1 Michael J. Carter 2003-09-12 11:44:14 EDT
I just tried this with RedHat 9 and I get the same result.
Comment 2 Scott Feldman 2004-03-03 22:24:58 EST
Is Spanning Tree Protocol (STP) enabled on the switch you're 
connected to?  When the driver is loaded, link is activated, which 
would start the STP algorithm on the switch.  It may take up to 30 
seconds before the switch lets traffic pass through the switch port.  
This would block getting a DHCP address.

It's just a guess.  Something to look into.  If it is STP, you can 
disable that from the switch management console.
Comment 3 Michael J. Carter 2004-03-10 18:41:13 EST
I'll look into this just to rule it out, but if this were the problem
why does dhcp work normally after a manual installation of the OS?

I was assuming there was some difference between the boot kernel on
the install media and that in the distro.
Comment 4 Bill Heiden 2004-03-10 20:47:53 EST
 Two things:

 - RH v9.0 is not qualified for the Proliant.  HP/Compaq is not 
actively supporting this release, plus you'll need a special driver 
for the Proliant to recognize the CDROM (available at HP/Compaq 
website).

 - The suggestion about turning off STP at the switch worked like a 
charm for me with a similar problem.  After switching some Proliants 
from 100 baseT to 1000 baseT, we encountered a problem were not all 
our NFS directories were not mounting.  The following clue was found 
in /var/log/messages when the system tried mount NFS directories:

Mar  9 19:20:33 quartz mount: mount: RPC: Remote system error - No 
route to host

Immediately after this message some of the mount requests succeeded, 
while the ones prior to the message failed.  This was being caused by 
the latency introduced by STP at the switch.  Try turning off STP! 
Comment 5 Michael J. Carter 2004-03-12 16:04:11 EST
The RH v9.0 comment was just an extra data point - RHEL 3 wasn't out
at the time.

I've just verified that STP is off on the 3Com 4900 gig switch.
Comment 6 Jeff Garzik 2004-06-14 13:16:34 EDT
How is this looking in Fedora Core or RHEL3?
Comment 7 Michael J. Carter 2004-06-14 14:32:35 EDT
Does not work on RHEL3 - resorted to putting ks.cfg file on floppy.
Interface does come up during kickstart when a static network
assignment is made in the ks.cfg file.

Have not tried Fedora. I don't currently have a HP GL380G3 w/ HP
NC6136 fiber card that isn't in production.

mjc
Comment 8 John W. Linville 2005-02-28 11:09:00 EST
Could you attach the output from running 'sysreport'?  Thanks!
Comment 9 Michael J. Carter 2005-02-28 12:27:50 EST
Created attachment 111488 [details]
'sysreport' output
Comment 10 John W. Linville 2005-03-11 10:52:37 EST
Can you see any DHCP traffic on the wire (during the install)? 
Perhaps you can attach the output of something like tcpdump or
ethereal running at the DHCP server (hopefully on an isolated
network)?  Thanks!

Comment 11 Michael J. Carter 2005-03-11 11:25:33 EST
Unfortunately, I don't have any of these boxes that aren't now in
production.
Comment 12 John W. Linville 2005-03-14 12:36:18 EST
Considering that there have been a number of e1000 updates in RHEL3
since when this was reported (and even since comment 7) and there
don't appear to be any other complaints along these lines, I'm going
to have to close this out.

If you or anyone else is still having this problem with the latest
RHEL3 update, please reopen this bug so that we can investigate further.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.