Bug 1042811 - tomcat6 service restarts will cause a duplicated command-line arguments
Summary: tomcat6 service restarts will cause a duplicated command-line arguments
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tomcat6
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: David Knox
QA Contact: tomcat-qe
URL:
Whiteboard:
Depends On:
Blocks: 1075802
TreeView+ depends on / blocked
 
Reported: 2013-12-13 12:36 UTC by Dasharath Masirkar
Modified: 2018-12-03 20:56 UTC (History)
6 users (show)

Fixed In Version: tomcat6-6.0.24-89.el6
Doc Type: Bug Fix
Doc Text:
Previously, the tomcat6 service restart incorrectly caused duplication in JVM command-line arguments, and the "-Djavax.sql.DataSource.Factory=org.apache.commons.dbcp.BasicDataSourceFactory" duplicate argument appeared. This has been fixed, and tomcat6 now starts without duplicate JVM arguments.
Clone Of:
Environment:
Last Closed: 2015-07-22 07:27:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1461 normal SHIPPED_LIVE tomcat6 bug fix and enhancement update 2015-07-21 14:14:55 UTC

Description Dasharath Masirkar 2013-12-13 12:36:05 UTC
Description of problem:
tomcat6 service restarts will cause a duplicated command-line arguments

Version-Release number of selected component (if applicable):
tomcat 6

How reproducible:
always

Steps to Reproduce:
1. [root@localhost ~]# service tomcat6 restart

Stopping tomcat6:                                          [  OK  ]
Starting tomcat6:                                          [  OK  ]


2. [root@localhost ~]# service tomcat6 status

tomcat6 (pid 3243) is running...                           [  OK  ]

3. [root@localhost ~]# ps -ef | grep 3243

tomcat    3243     1  5 17:13 ?        00:00:01 /usr/lib/jvm/java/bin/java -Djavax.sql.DataSource.Factory=org.apache.commons.dbcp.BasicDataSourceFactory -Djavax.sql.DataSource.Factory=org.apache.commons.dbcp.BasicDataSourceFactory -classpath :/usr/share/tomcat6/bin/bootstrap.jar:/usr/share/tomcat6/bin/tomcat-juli.jar:/usr/share/java/commons-daemon.jar -Dcatalina.base=/usr/share/tomcat6 -Dcatalina.home=/usr/share/tomcat6 -Djava.endorsed.dirs= -Djava.io.tmpdir=/var/cache/tomcat6/temp -Djava.util.logging.config.file=/usr/share/tomcat6/conf/logging.properties -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager org.apache.catalina.startup.Bootstrap start
root      3378  2495  0 17:13 pts/1    00:00:00 grep 3243

4. [root@localhost ~]# tr \\0 \\n </proc/3243/cmdline

/usr/lib/jvm/java/bin/java

-Djavax.sql.DataSource.Factory=org.apache.commons.dbcp.BasicDataSourceFactory

-Djavax.sql.DataSource.Factory=org.apache.commons.dbcp.BasicDataSourceFactory

-classpath
:/usr/share/tomcat6/bin/bootstrap.jar:/usr/share/tomcat6/bin/tomcat-juli.jar:/usr/share/java/commons-daemon.jar
-Dcatalina.base=/usr/share/tomcat6
-Dcatalina.home=/usr/share/tomcat6
-Djava.endorsed.dirs=
-Djava.io.tmpdir=/var/cache/tomcat6/temp
-Djava.util.logging.config.file=/usr/share/tomcat6/conf/logging.properties
-Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
org.apache.catalina.startup.Bootstrap
start

Actual results:
The tomcat6 will get start with below duplicate jvm argument.

-Djavax.sql.DataSource.Factory=org.apache.commons.dbcp.BasicDataSourceFactory


Expected results:

The tomcat6 has to start without duplicate jvm argument


Additional info:

Comment 4 fgoldefu 2015-04-08 07:15:53 UTC
Last build from Errata RHBA-2015:20040-02 (tomcat6-6.0.24-88.el6) brings back this bug => regression.

Comment 7 Jan Stourac 2015-06-04 09:10:39 UTC
Test passed -> verified.

Comment 9 errata-xmlrpc 2015-07-22 07:27:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1461.html


Note You need to log in before you can comment on or make changes to this bug.