Bug 104283 - tigon3 module (tg3.o) does not support certain useful driver parameters
tigon3 module (tg3.o) does not support certain useful driver parameters
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-11 20:29 EDT by Mark Fasheh
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-12 03:58:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Fasheh 2003-09-11 20:29:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The Tigon3 (tg3.o) driver does not use any of the more useful module parameters.
The three I'm referring to are 'full_duplex', 'speed' and 
'autonegotiation'. Of course, one can use ethtool after the module has loaded
but I've got some customers here who really need this to be done at module load
time.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Just run modinfo on the module:
/sbin/modinfo /lib/modules/`uname -r`/kernel/drivers/net/tg3.o
and you will see that it only supports a debugging parameter.    

Additional info:
Comment 1 Arjan van de Ven 2003-09-12 03:58:02 EDT
not a bug;
just put
post-install tg3 ethtool ......
in /etc/modules.conf and ethtool gets run at module load time.

Note You need to log in before you can comment on or make changes to this bug.