Bug 104293 - r-c-printer doesn't generate correct URI's for SMB printers
r-c-printer doesn't generate correct URI's for SMB printers
Status: CLOSED ERRATA
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-printer (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-12 01:48 EDT by Gary Peck
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-17 04:56:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Peck 2003-09-12 01:48:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Epiphany/0.9.3

Description of problem:
When setting up a Networked Windows (SMB) printer, if I don't enter all the
information in the "Queue type" tab, the DeviceURI generated for the printer (as
seen in /etc/cups/printers.conf) is incorrect. As a result, jobs sent to this
printer fail with NT_STATUS_ACCESS_DENIED errors.

Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.73-1

How reproducible:
Always

Steps to Reproduce:
1. Run redhat-config-printer.
2. Select an SMB printer in the printer list, and click Edit.
3. Select the "Queue type" tab.
4. Enter the share name and hostname of the networked printer, but leave User,
Password, and Workgroup blank.
5. Click OK, and then Apply.
6. Try printing something to this printer.

Actual Results:  The print job stays in the local queue. If I look in
/var/log/cups/error_log, it tells me that it couldn't connect because of a
NT_STATUS_ACCESS_DENIED error.

Expected Results:  The printer should receive the job and print it.

Additional info:

When I enter only the share and computer name, the URI generated is
smb:///computer_name/share. When I enter a User too, it generates
smb://user/computer_name/share. Both of these seem to be incorrect. Only when I
enter a password does it generate smb://user:password@computer_name/share, which
allows the print job to print.

The computer I'm connecting to is running Windows XP and doesn't require any
username or password to connect. I have tested this out using smbclient.
Furthermore, the above steps work with any random password I enter into
r-c-printer's Password box. This reinforces my suspicion that the problem is in
the syntax and not an actual authorization problem.

I'm running an up-to-date rawhide system. This includes:

cups-1.1.19-11
samba-3.0.0-5rc1
rawhide-release-20030907-1
Comment 1 Tim Waugh 2003-09-12 06:41:51 EDT
Thanks.  Should be fixed in redhat-config-printer-0.6.75-1.
Comment 2 Tim Waugh 2003-09-17 04:56:12 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-276.html

Note You need to log in before you can comment on or make changes to this bug.