Bug 104301 - plug/unplug USB FDD causes system lock up
plug/unplug USB FDD causes system lock up
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-12 06:04 EDT by Shinya Narahara
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 19:43:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shinya Narahara 2003-09-12 06:04:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.1.4322)

Description of problem:
Linux system locks up when mount FD on USB FDD.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.plug USB FDD and mount/umount FD on it.
2.unplug USB FDD
3.plug USB FDD again and mount FD on it


Actual Results:  system hang up

Expected Results:  mount properly.

Additional info:

The first mounting FD is succeed properly, when USB FDD is plugged
first time. after unmount it, unplug USB FD and plug USB FDD,
mounting FD causes system hang up.
The usb-storage.o module isn't unloaded automatically when the USB
FDD is unplugged. On ia32, it is unloaded automatically. 
We guess the usb-storage.o module is busy even if the USB FDD is unplugged,
thus 2nd "mount" can't work.
Comment 1 Pete Zaitcev 2003-09-12 13:36:55 EDT
This sounds like the problem with iorl which we fixed.
Hitachi should ensure they use updates from the "Sushi" channel.
The fix was in .419 or so.
Comment 2 Pete Zaitcev 2003-09-12 13:41:47 EDT
See also bug 102620 (don't dup! may be different cause!)
Comment 3 Shinya Narahara 2003-10-03 04:05:19 EDT
We've tested this with kernel-2.4.21-3.EL, but this is not fixed.
The shell which execute "mount" stops suddenly, although kernel doesn't crush.
The cause is same, usb-storage.o is staying however plug/unplug usb FDD.
Could you please reproduce this?
Comment 4 Shinya Narahara 2003-10-29 01:15:44 EST
kernel-2.4.21-4.EL has same issue...
Why don't you confirm and fix this?
Comment 5 Pete Zaitcev 2003-12-11 16:19:54 EST
Please test this:

ftp://people.redhat.com/zaitcev/utest/
 kernel*-2.4.21-6.usbstor1.1.EL.ia64.rpm
Comment 6 Shinya Narahara 2003-12-12 02:14:06 EST
Unfortunately the issue hasn't been fixed.

BTY, we found a strange process when this issue was occured.
It is dead with handling /dev/sdc(USB FD)

# ps aux | grep sd
root  19812  0.0  0.0  #### ####  tty1 D   16:17  0:00 portx:/dev/sdc

Is this one of a cause?
Comment 7 Pete Zaitcev 2004-08-19 19:30:31 EDT
Is this an issue with RHEL3 U3?
Comment 8 Ernie Petrides 2005-10-05 19:43:22 EDT
Closing due to lack of response.

Note You need to log in before you can comment on or make changes to this bug.