Bug 10431 - Weird highlighting problem with "kd"
Summary: Weird highlighting problem with "kd"
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: vim   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-30 07:27 UTC by Stephen Rasku
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-07 20:26:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen Rasku 2000-03-30 07:27:56 UTC
If I put a line of kd's on the screen in vim-5.6-7, eg:

kd kd kd kd kd

All of the kd's except for the first one will be highlighted.  In gvim, it
is highlighted with a yellow background.  In vim, it is highlighted with a
brown background.  It happens either with or without a .vimrc present.

Comment 1 Bernhard Rosenkraenzer 2000-04-07 20:26:59 UTC
This is probably not a bug, but the syntax highlighting feature.
Apparently "kd" has a meaning in some language and your file is recognized as
being of that type. (It's the same as all further characters being highlighted
when you use /* in a C file).

If you don't like the highlighting feature, edit
/usr/share/vim/vim56/macros/vimrc or override it in a local ~/.vimrc.

Comment 2 Stephen Rasku 2000-05-17 16:35:59 UTC
This is actually because search will highlight all instances of the search
pattern on the screen.  Combined with this, is the fact that this version of vim
will remember your last search pattern and highlight it when you re-open a bug.

Comment 3 Stephen Rasku 2000-05-24 07:16:59 UTC
That should be "re-open a file" not "re-open a bug".  By the way, is there a way
to turn this off?


Note You need to log in before you can comment on or make changes to this bug.