Bug 104318 - GTK support for util-linux (floppy-0.12) is horked
GTK support for util-linux (floppy-0.12) is horked
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: util-linux (Show other bugs)
1.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-12 10:46 EDT by Michael Lee Yohe
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-15 07:28:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Lee Yohe 2003-09-12 10:46:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030722
Galeon/1.3.8

Description of problem:
During the configure process for floppy-0.12, there is an error reported due to
a highly bogus path.

checking for gtk-config... /asfd/jkl/bin/gtk-config
checking for GTK - version >= 1.2.0... ./configure: line 1:
/asfd/jkl/bin/gtk-config: No such file or directory
./configure: line 1: /asfd/jkl/bin/gtk-config: No such file or directory
./configure: line 1: /asfd/jkl/bin/gtk-config: No such file or directory
./configure: line 1: /asfd/jkl/bin/gtk-config: No such file or directory
./configure: line 1: /asfd/jkl/bin/gtk-config: No such file or directory
no
*** Could not run GTK test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK was incorrectly installed
*** or that you have moved GTK since it was installed. In the latter case, you
*** may want to edit the gtk-config script: /asfd/jkl/bin/gtk-config

No modifications have been made, and I obviously don't have a BS path like
/asdf/jkl.  Was this done on purpose?  If so, could this be patched out?

Version-Release number of selected component (if applicable):
util-linux-2.11y-29

How reproducible:
Always

Steps to Reproduce:
1. see description
2.
3.
    

Actual Results:  You see the error in the configure process above.

Expected Results:  Should be corrected so that GTK support will be built *or*
that part of the configure process should be patched out so that something that
unclean would never appear.

Additional info:
Comment 1 Elliot Lee 2003-09-15 07:28:14 EDT
This intentional behaviour is the way I have chosen to disable GTK support. There's no 
apparent benefit to stripping GTK detection from configure altogether, and doing so would 
be a lot more complicated and harder to maintain, so I see no reason to change.

Note You need to log in before you can comment on or make changes to this bug.