Bug 1043375 - Remove invalid form artifact from jboss-bpm-example (Big App)
Summary: Remove invalid form artifact from jboss-bpm-example (Big App)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ER 7
: 6.0.0
Assignee: Kris Verlaenen
QA Contact: Jan Hrcek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-16 06:43 UTC by Jan Hrcek
Modified: 2014-08-06 20:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 20:09:58 UTC
Type: Bug


Attachments (Terms of Use)
Invalid form in the Big App (400.75 KB, image/png)
2013-12-16 06:43 UTC, Jan Hrcek
no flags Details
Typo in big app's repo name (33.07 KB, image/png)
2013-12-16 07:21 UTC, Jan Hrcek
no flags Details

Description Jan Hrcek 2013-12-16 06:43:20 UTC
Created attachment 837121 [details]
Invalid form in the Big App

Description of problem:
The Mortgage application should contain exactly 5 form modeler forms (1 process start form + 4 x 1 for each of the human tasks in the MortgageApplication process). But it contains 6 - one of them is invalid and cannot be opened.

Please remove the invalid form artifact "MortgageApplication.MortgageApplication-taskform" from the Big app's git repository. This artifact seems to be some leftover created during the development of the big app and was later not deleted. When I click it in an effort to open in in form modeler I get the following error:

Error getting form default://master@MortageApplication/MortgageApplication/src/main/resources/com/redhat/bpms/examples/mortgage/MortgageApplication.MortgageApplication-taskform.form: java.lang.NullPointerException


Version-Release number of selected component (if applicable):
BPMS 6.0.0 ER5

How reproducible:
Always

Steps to Reproduce:
1. install jboss-bpm-example (Big App) in BPMS 6.0.0 ER5 (For example using Eric Schabell's project https://github.com/eschabell/bpms-mortgage-demo)
2. In Project authoring select MortgageApplication open a list of Form definitions and click MortgageApplication.MortgageApplication-taskform to open it

Actual results:
You will see an error pasted in description

Expected results:
There should be no error when opening the big app's artifacts

Comment 1 Jan Hrcek 2013-12-16 07:21:06 UTC
Created attachment 837124 [details]
Typo in big app's repo name

Comment 2 Jan Hrcek 2013-12-16 07:22:08 UTC
And while you're at it, could you please fix the typo in big app's repository name (see screenshot).. I really don't want to open separate bugzilla for such issue.

Comment 4 Mauricio Salatino 2013-12-16 08:16:56 UTC
Hi Jan,
I don't have access to that repository you should ask to eschabell to update the example. That's not maintained by the developer's team. Not sure if I should mark this as modified/resolved or just close this BZ

Comment 5 Jan Hrcek 2013-12-16 08:30:24 UTC
Hello Mauricio, I believe it should be handled by the developper of the bigapp, Babak Mozaffari. However I was not sure which other product component should I  use so that this bugzilla gets to him.

@Babak, can you please take a look at this issue / clarify who's responsible for maintenance of the Big App?

Comment 6 Kris Verlaenen 2013-12-16 13:41:41 UTC
I've taken over responsibility for the BigApp an will fix.

Comment 7 Kris Verlaenen 2013-12-16 15:43:34 UTC
Fixed: https://github.com/jboss-integration/jboss-bpm-example-app/commit/4e1a69ab29c5b34d9272cb3d56c34888486f8ac5

Note that the typo shown in the screenshot is the repository name, which the user should specify himself when cloning the repo.  So, afaik, this was a user typo, not something we should fix in the repo itself.

Comment 8 Jan Hrcek 2014-01-07 12:16:14 UTC
Ok, the form artifact is no logner part of BPM Example app repository. Verified with BPMS 6.0.0 ER7


Note You need to log in before you can comment on or make changes to this bug.