Red Hat Bugzilla – Bug 104341
PHP 4.3.3-2 has bad apache dependancy
Last modified: 2007-04-18 12:57:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.2) Gecko/20030716
Description of problem:
From the php.4.3.3-2 spec file:
BuildRequires: httpd-devel >= 2.0.40-6,
However, when compiling 4.3.3-2 you eventually get this message:
Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS... no
checking for Apache 1.x module support... no
checking for member fd in BUFF *... (cached) no
checking for mod_charset compatibility option... no
checking for Apache 2.0 filter-module support via DSO through APXS... no
checking for Apache 2.0 handler-module support via DSO through APXS...
apxs:Error: Invalid query string `APU_BINDIR'.
apxs:Error: Invalid query string `APR_BINDIR'.
./configure: line 1: /apu-config: No such file or directory
./configure: line 1: /apr-config: No such file or directory
configure: error: Please note that Apache version >= 2.0.44 is required.
error: Bad exit status from /var/tmp/rpm-tmp.17096 (%build)
The BuildRequires should be updated to:
BuildRequires: httpd-devel >= 2.0.44
Version-Release number of selected component (if applicable):
Steps to Reproduce:
1.rpm -ivh php-4.3.3-2.src.rpm
2.rpmbuild -bb /usr/src/redhat/SPECS/php.spec
Actual Results: See description
Expected Results: php successfully compiled
This is new to 4.3.3; 4.3.2 compiled fine with httpd-2.0.40-11.7
I also believe that there should be a dependancy BuildRequires: libelf-devel
until net-snmp is re-issued.
Oh, I forgot. Someone might want to see if mod_php has runtime needs such that
the spec file's "Requires" statement has to be updated to >= 2.0.44, too. I
don't know if its just a compile problem or a deeper design change.
Thanks, I'll fix the httpd-devel requires as you indicate.
To the second question: the module packages we build depend on a version of
httpd which has a matching module ABI using the httpd-mmn requirement; so no,
you couldn't install a php-4.3.3 which was built against 2.0.47 on a system
which only had httpd-2.0.40.