Bug 1043427 - Emacs windows loses Window Manager border under KDE
Summary: Emacs windows loses Window Manager border under KDE
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Hracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-16 09:59 UTC by Paul Black
Modified: 2015-06-29 13:32 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-29 13:32:44 UTC


Attachments (Terms of Use)
Emacs without window manager border (256.39 KB, image/png)
2013-12-16 09:59 UTC, Paul Black
no flags Details

Description Paul Black 2013-12-16 09:59:43 UTC
Created attachment 837183 [details]
Emacs without window manager border

Description of problem:
When I start emacs the window manager border disappears after a period of time (seems to stay if mouse is not over emacs window). This is running under KDE (kwin). Not seeing this behaviour with any other applications.

Version-Release number of selected component (if applicable):
emacs-24.3-13.fc20.x86_64

How reproducible:
Very

Steps to Reproduce:
1. Start emacs under KDE.
2. Move mouse over emacs window.
3.

Actual results:
If present, the window manager border disappears.

Expected results:
The window manager border doesn't disappear.


Additional info:
No .emacs file and no .Xdefaults.
Didn't spot any similar bugs for either emacs or kde-workspace(kwin).

Comment 1 Neal Becker 2013-12-23 19:07:59 UTC
Confirm I see the same symptom.  But only when emacs is run remotely via ssh -X.  The window manager border and the minibuffer disappear.

Happens both on nouveau and on nvidia blob.

Does NOT happen under gnome.

Never happened before update to f20.

Comment 2 Neal Becker 2013-12-24 18:45:11 UTC
I rebuilt emacs from srpm changing toolkit to lucid, and it seems to be working fine.

Comment 3 Andris Pavenis 2013-12-29 14:03:14 UTC
Confirmed in KDE with F20 x86_64 when running locally (I have not tried
remotely).

This problem makes emacs unusable (except than in terminal) as also minibuffer disappers.

Comment 4 Paul Black 2014-01-03 08:51:52 UTC
This has now gone away for me on my two machines. I didn't notice what particular package was updated to "fix" this. At a first glance, 3 packages were updated that emacs directly depends on: libtiff, libselinux and dbus-libs. There didn't seem to be any obvious updates to KDE or its libs.

At least it works now!

Comment 5 Fedora End Of Life 2015-05-29 10:00:12 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 6 Fedora End Of Life 2015-06-29 13:32:44 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.