Bug 1043550 - libvrit: logs mundane messages at error level
Summary: libvrit: logs mundane messages at error level
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1079602 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-16 15:27 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2014-05-08 10:09 UTC (History)
11 users (show)

Fixed In Version: libvirt-1.1.3.5-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-08 10:09:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Zbigniew Jędrzejewski-Szmek 2013-12-16 15:27:31 UTC
Description of problem:
libvirtd logs in a recently installed F20 VM:

Dec 14 22:28:39 vm1 libvirtd[768]: libvirt version: 1.1.3.1, package: 2.fc20 (Fedora Project, 2013-11-17-23:28
Dec 14 22:28:39 vm1 libvirtd[768]: Module /usr/lib64/libvirt/connection-driver/libvirt_driver_xen.so not acces
Dec 14 22:28:39 vm1 libvirtd[768]: Module /usr/lib64/libvirt/connection-driver/libvirt_driver_libxl.so not acc
Dec 14 22:28:39 vm1 libvirtd[768]: Module /usr/lib64/libvirt/connection-driver/libvirt_driver_lxc.so not acces
Dec 14 22:28:39 vm1 libvirtd[768]: Module /usr/lib64/libvirt/connection-driver/libvirt_driver_uml.so not acces
Dec 14 22:28:39 vm1 libvirtd[768]: Module /usr/lib64/libvirt/connection-driver/libvirt_driver_vbox.so not acce

Those messages have PRIORITY=2:
LOG_CRIT       critical conditions

Version-Release number of selected component (if applicable):
libvirt-daemon-1.1.3.1-2.fc20.x86_64

How reproducible:
100%

Expected results:
I don't expect *any* package to log anything with level above LOG_INFO during a normal, uneventful boot.
Not having xen, lxc, uml, vbox related stuff is too be expected. Also that the daemon starts when configured
to do so is not unexpected. Actually systemd already logs that for *every* daemon, so repeating that except
at debug level (when configured to enable debug messages) doesn't make sense.

Comment 1 Ján Tomko 2014-04-16 07:51:43 UTC
This should be fixed upstream by:
commit 21d370f0b90e9ff1c9e9c8e454130b6446d7eb89
Author:     Daniel P. Berrange <berrange@redhat.com>
CommitDate: 2014-02-28 17:37:38 +0000

    Fix journald PRIORITY values
    
    The systemd journal expects log record PRIORITY values to
    be encoded using the syslog compatible numbering scheme,
    not libvirt's own native numbering scheme. We must therefore
    apply a conversion.
    
    Signed-off-by: Daniel P. Berrange <berrange@redhat.com>

git describe: v1.2.2-rc2-22-g21d370f contains: v1.2.2~11

Backported on v1.1.3-maint as v1.1.3.4-18-g18dfd38

Comment 2 Ján Tomko 2014-05-02 20:47:12 UTC
*** Bug 1079602 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2014-05-03 22:56:50 UTC
libvirt-1.1.3.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libvirt-1.1.3.5-1.fc20

Comment 4 Fedora Update System 2014-05-06 03:36:52 UTC
Package libvirt-1.1.3.5-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvirt-1.1.3.5-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6018/libvirt-1.1.3.5-1.fc20
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-05-08 10:09:13 UTC
libvirt-1.1.3.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.