Bug 1043564 - [abrt] hamster-time-tracker-1.03.3-2.fc20: idle.py:23:<module>:ImportError: No module named gconf
Summary: [abrt] hamster-time-tracker-1.03.3-2.fc20: idle.py:23:<module>:ImportError: N...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hamster-time-tracker
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ankur Sinha (FranciscoD)
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:8ddc4dc7334b0b00642a1813b35...
: 1044197 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-16 16:21 UTC by Jared Smith
Modified: 2014-01-08 07:51 UTC (History)
5 users (show)

Fixed In Version: hamster-time-tracker-1.03.3-6.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-31 19:00:46 UTC


Attachments (Terms of Use)
File: backtrace (6.71 KB, text/plain)
2013-12-16 16:22 UTC, Jared Smith
no flags Details
File: environ (965 bytes, text/plain)
2013-12-16 16:22 UTC, Jared Smith
no flags Details

Description Jared Smith 2013-12-16 16:21:57 UTC
Description of problem:
Installed hamster, and then tried to install the Gnome Shell Extension from https://extensions.gnome.org/extension/425/project-hamster-extension/.  That caused the crash

Version-Release number of selected component:
hamster-time-tracker-1.03.3-2.fc20

Additional info:
reporter:       libreport-2.1.9
cmdline:        /usr/bin/python /usr/bin/hamster-service
executable:     /usr/bin/hamster-service
kernel:         3.11.10-300.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            1975

Truncated backtrace:
#1 <module> in /usr/lib/python2.7/site-packages/hamster/idle.py:23
#2 <module> in /usr/lib/python2.7/site-packages/hamster/lib/desktop.py:26
#3 <module> in /usr/bin/hamster-service:21

Comment 1 Jared Smith 2013-12-16 16:22:03 UTC
Created attachment 837305 [details]
File: backtrace

Comment 2 Jared Smith 2013-12-16 16:22:06 UTC
Created attachment 837306 [details]
File: environ

Comment 3 Jared Smith 2013-12-16 16:24:47 UTC
Actually, it crashes on startup, whether or not the GNOME Shell extension is installed or not.

Comment 4 Ankur Sinha (FranciscoD) 2013-12-16 23:18:08 UTC
(In reply to Jared Smith from comment #3)
> Actually, it crashes on startup, whether or not the GNOME Shell extension is
> installed or not.

Hi Jared,

Thank you for the bugreport. Looks like it's because of a missing gconf module:

 File "/usr/lib/python2.7/site-packages/hamster/idle.py", line 23, in <module>
    import gconf
ImportError: No module named gconf

Can you please install 'gnome-python2-gconf' and see if that fixes it? It seems like a missing "Requires" in the spec. 

Thanks,
Warm regards,
Ankur

Comment 5 Fedora Update System 2013-12-17 01:08:34 UTC
hamster-time-tracker-1.03.3-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/hamster-time-tracker-1.03.3-3.fc20

Comment 6 Fedora Update System 2013-12-17 19:05:48 UTC
Package hamster-time-tracker-1.03.3-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hamster-time-tracker-1.03.3-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23482/hamster-time-tracker-1.03.3-3.fc20
then log in and leave karma (feedback).

Comment 7 Jared Smith 2013-12-17 20:39:50 UTC
Thanks!  It was indeed a missing dependency in the spec file, and the new version in Koji fixed the issue.  I've left positive karma.

Comment 8 Ankur Sinha (FranciscoD) 2013-12-18 01:30:15 UTC
*** Bug 1044197 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2013-12-25 02:32:57 UTC
Package hamster-time-tracker-1.03.3-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hamster-time-tracker-1.03.3-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23482/hamster-time-tracker-1.03.3-4.fc20
then log in and leave karma (feedback).

Comment 10 lnie 2013-12-25 02:37:48 UTC
1.03.3-4.fc20 works fine

Comment 11 Fedora Update System 2013-12-29 18:23:29 UTC
hamster-time-tracker-1.03.3-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/hamster-time-tracker-1.03.3-6.fc19

Comment 12 Fedora Update System 2013-12-31 01:53:18 UTC
Package hamster-time-tracker-1.03.3-6.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hamster-time-tracker-1.03.3-6.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23482/hamster-time-tracker-1.03.3-6.fc20
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2013-12-31 19:00:46 UTC
hamster-time-tracker-1.03.3-6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2014-01-08 07:51:50 UTC
hamster-time-tracker-1.03.3-6.fc19 has been pushed to the Fedora 19 stable repository.


Note You need to log in before you can comment on or make changes to this bug.