Bug 1043659 - [abrt] gnome-shell-3.10.2.1-3.fc20: cogl_object_unref: Process /usr/bin/gnome-shell was killed by signal 11 (SIGSEGV)
Summary: [abrt] gnome-shell-3.10.2.1-3.fc20: cogl_object_unref: Process /usr/bin/gnome...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:1e4690e3d339183a7a2d658744c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-16 20:45 UTC by Christian Stadelmann
Modified: 2014-04-26 09:20 UTC (History)
8 users (show)

Fixed In Version: mutter-3.10.4-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-26 09:20:14 UTC


Attachments (Terms of Use)
File: backtrace (36.57 KB, text/plain)
2013-12-16 20:45 UTC, Christian Stadelmann
no flags Details
File: cgroup (172 bytes, text/plain)
2013-12-16 20:45 UTC, Christian Stadelmann
no flags Details
File: core_backtrace (21.15 KB, text/plain)
2013-12-16 20:45 UTC, Christian Stadelmann
no flags Details
File: dso_list (24.62 KB, text/plain)
2013-12-16 20:46 UTC, Christian Stadelmann
no flags Details
File: environ (1.38 KB, text/plain)
2013-12-16 20:46 UTC, Christian Stadelmann
no flags Details
File: limits (1.29 KB, text/plain)
2013-12-16 20:46 UTC, Christian Stadelmann
no flags Details
File: maps (110.97 KB, text/plain)
2013-12-16 20:46 UTC, Christian Stadelmann
no flags Details
File: open_fds (4.00 KB, text/plain)
2013-12-16 20:46 UTC, Christian Stadelmann
no flags Details
File: proc_pid_status (945 bytes, text/plain)
2013-12-16 20:46 UTC, Christian Stadelmann
no flags Details
File: var_log_messages (18.79 KB, text/plain)
2013-12-16 20:46 UTC, Christian Stadelmann
no flags Details

Description Christian Stadelmann 2013-12-16 20:45:45 UTC
Description of problem:
Steps to reproduce this bug:
1. start gtk3-demo
2. run Entry → Delayed Search Entry
3. type many characters, use Ctrl+A, Ctrl+C, Ctrl+V to 'write' faster

What happens: Gnome-shell crashes

Possible reason: window size is too big

Even though this bug has not appeared in a real-use scenario I think it should be fixed. I think windows (GUI-applications) should not be able to break gnome-shell.
In this case 'disabling all gnome-shell extensions' is completely useless.

Version-Release number of selected component:
gnome-shell-3.10.2.1-3.fc20

Additional info:
reporter:       libreport-2.1.9
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: cogl_object_unref
executable:     /usr/bin/gnome-shell
kernel:         3.11.10-301.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 cogl_object_unref at ./cogl-object.c:103
 #1 build_and_scan_frame_mask at compositor/meta-window-actor.c:2222
 #2 meta_window_actor_update_shape_region at compositor/meta-window-actor.c:2253
 #3 check_needs_reshape at compositor/meta-window-actor.c:2321
 #4 meta_window_actor_handle_updates at compositor/meta-window-actor.c:2392
 #5 meta_window_actor_thaw at compositor/meta-window-actor.c:1032
 #6 meta_window_update_sync_request_counter at core/window.c:9669
 #7 event_callback at core/display.c:2270
 #8 filter_func at ui/ui.c:253
 #9 gdk_event_apply_filters at gdkeventsource.c:81

Comment 1 Christian Stadelmann 2013-12-16 20:45:50 UTC
Created attachment 837406 [details]
File: backtrace

Comment 2 Christian Stadelmann 2013-12-16 20:45:52 UTC
Created attachment 837407 [details]
File: cgroup

Comment 3 Christian Stadelmann 2013-12-16 20:45:57 UTC
Created attachment 837408 [details]
File: core_backtrace

Comment 4 Christian Stadelmann 2013-12-16 20:46:00 UTC
Created attachment 837409 [details]
File: dso_list

Comment 5 Christian Stadelmann 2013-12-16 20:46:02 UTC
Created attachment 837410 [details]
File: environ

Comment 6 Christian Stadelmann 2013-12-16 20:46:04 UTC
Created attachment 837411 [details]
File: limits

Comment 7 Christian Stadelmann 2013-12-16 20:46:09 UTC
Created attachment 837412 [details]
File: maps

Comment 8 Christian Stadelmann 2013-12-16 20:46:11 UTC
Created attachment 837413 [details]
File: open_fds

Comment 9 Christian Stadelmann 2013-12-16 20:46:12 UTC
Created attachment 837414 [details]
File: proc_pid_status

Comment 10 Christian Stadelmann 2013-12-16 20:46:15 UTC
Created attachment 837415 [details]
File: var_log_messages

Comment 11 Elliott Sales de Andrade 2014-04-05 05:13:17 UTC
Looks like bug 1051458, which mentions being fixed upstream, and marked as a duplicate of bug 1027832, but I can't view that bug.


Here is a "real-use scenario" that triggers this problem:
https://github.com/obspy/obspy/issues/768

Comment 12 Florian Müllner 2014-04-10 13:11:21 UTC
(In reply to Elliott Sales de Andrade from comment #11)
> Looks like bug 1051458, which mentions being fixed upstream, and marked as a
> duplicate of bug 1027832, but I can't view that bug.

Yeah - https://bugzilla.gnome.org/show_bug.cgi?id=722266 is the fixed upstream bug, but the patch hasn't been backported to 3.10 (yet). Given that it's still unlcear if and when there'll be an update to GNOME 3.12, I'll prepare an update with the fix.

Comment 13 Fedora Update System 2014-04-10 14:04:52 UTC
mutter-3.10.4-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mutter-3.10.4-2.fc20

Comment 14 Fedora Update System 2014-04-14 22:37:20 UTC
Package mutter-3.10.4-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mutter-3.10.4-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-4995/mutter-3.10.4-2.fc20
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2014-04-26 09:20:14 UTC
mutter-3.10.4-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.