Bug 1043682 - can't install python-pthreading > requires python 2.6
Summary: can't install python-pthreading > requires python 2.6
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-pthreading
Version: 7.0
Hardware: Unspecified
OS: Unspecified
Target Milestone: rc
: ---
Assignee: Yaniv Bronhaim
QA Contact:
Whiteboard: infra
Depends On:
TreeView+ depends on / blocked
Reported: 2013-12-16 22:12 UTC by Ohad Basan
Modified: 2014-07-29 08:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2014-07-29 08:00:34 UTC
Target Upstream Version:

Attachments (Terms of Use)

Description Ohad Basan 2013-12-16 22:12:29 UTC
Description of problem:

python-pthreading is failing to install
[root@cinteg03 vdsm]# yum install python-pthreading
Loaded plugins: product-id, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package python-pthreading.noarch 0:0.1.2-1.el6ev will be installed
--> Processing Dependency: python(abi) = 2.6 for package: python-pthreading-0.1.2-1.el6ev.noarch
--> Finished Dependency Resolution
Error: Package: python-pthreading-0.1.2-1.el6ev.noarch (qa-latest)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-10.el7.x86_64 (@anaconda/7.0)
               python(abi) = 2.7
               python(abi) = 2.7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 1 RHEL Program Management 2014-03-24 05:50:02 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 2 Yaniv Bronhaim 2014-07-29 08:00:34 UTC
Hey Ohad, 
You use here python-pthreading.noarch 0:0.1.2-1.el6ev which targeted to el6, and you're right, it requires python 2.6, and won't work on rhel7 that way (bare in mind, python-pthreading includes compiled code and therefore it is linked with the python code during completion) , anyhow, if you check the epel7 package it does required python 2.7 and works fine.

rpm -qpR http://download.devel.redhat.com/brewroot/packages/python-pthreading/0.1.3/3.el7ev/noarch/python-pthreading-0.1.3-3.el7ev.noarch.rpm
python(abi) = 2.7
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1

Note You need to log in before you can comment on or make changes to this bug.